Clone SD card

Hi, I made a clone of the SD card using Win32DiskImager. The copy was successful but the Home Assistant browser interface does not start. I can access Hassio’s folders with Putty and also with Windows Explorer. I tried on two different Raspberry: the “old” sd works with the browser while the new one does not. What do you suggest?

Could you share your HA log output here (perhaps with debug logging enabled)?

Did you have both the old and new ones running and using either a DHCP reserved IP or static IP in your setup?

You could also create a checksum of both SD cards to verify the clones are, in fact, identical.

I have no log. I cannot access ha via browser and so I cannot read no logs.
I not use DHCP but static IP

You said you can access it using Putty, so I’m assuming you can get to home-assistant.log which is in your .homeassistant directory (where this directory is will depend on how you installed HA). If you can manage to find it, you can post the contents here.

The file home-assistant.log is empty

I would say the Clone SD card broken

put old one in boot it up goto

supervisor -> snapshots and do one get is off HA

install this

been using it over 1 year and have done 2 restores (me playing did know what i was doing)


Or if you have a NAS and are weary of storing your data on someone else’s computer in the cloud:

I alredy have the backup of snapshots over cloud. The SD card is ok and os system running. Only Hassio is down.

Diskimager has a problem copying an image to a ‘smaller’ card.
This is dependent on how the manufacturer specified the byte layout and how the card was subsequently formatted. (yeah I know it will format the card as it is writing the image) the point is the cards ‘may’ be different.
Say (and I’m making these numbers up)
30,284 bytes card1
30,280 bytes card2
So it would have no problem copying card2 to card1 but not visa versa
(I use picore players around the house and buy (say) 10 off 8gb cards from the same manufacturer at a time)
Only had this problem 3 times since about 2008

Try a different card, rinse and repeat

This may seem like a stupid question but have you tried just doing a new HA install and then using one of your snapshots ?

Just FYI…I have been very happy using the ApplePiBaker Tools for cloning on my MAC from 64GB SD, and then to a 256GB and to an 8GB (

1 Like

Yes, this is the case. Different vendors produce a bit different cards in terms of number of sectors. Win32DiskManager recognized it and ask me whether I want to shrink it as the remaining sectors appears to be empty. However, it did not boot.

Just FYI…I have been very happy using the ApplePiBaker Tools

Thanks - this helped me a lot.