Cloud component and Smartthings

Hi all,
Total newbie here.
I am trying to integrate the Smartthings Hub v3 and I have created a Personal Access Token. From there and from what I can make out, there are two ways forward;

  1. Using Nabu Casa. I have subscribed to this but I don’t know where the resulting remote URL should be entered. For what its worth, in Home Assistant Cloud, I see under Nabu Casa Account - Cloud connection status - Connected
  2. I have also tried adding the External URL to the config. Should this be the Nabu Casa address or something else?

Can someone please point me in the right direction at least? I have looked in other threads with the same issue but I cannot see a fix.

Please help…

I’m doing exactly what you’re trying to do.
It seems the key is to

  1. Set up in Home Assistant. This will automatically create the web hook you need.
  2. Create your Personal Access Token in SmartThings. (Looks like you have done that.)
  3. Then add the SmartThings integration in Home Assistant. This should automatically copy the web hook that created.
  4. Put the Personal Access Token into the SmartThings dialog.
  5. Select which SmartThings Location to add to Home Assistant
  6. This will open a web app window that allows you to log into your SmartThings account and authorize the integration.
    If you’re already doing all that. Can you tell us specifically where this procedure seems to go off the rails?

Hi Russell,
I THINK I have done step 1; in Home Assistant Cloud, I see under Nabu Casa Account - Cloud connection status - Connected
But I am not sure if this is correct? Is there anywhere I should add the URL from Nabu Casa?
Step 2 - Yes done
Step 3 - This is where the it falls apart; when try integration with Smartthings, I get a message saying “config flow could not be loaded”. I found a thread for that Integration Smartthings fails - Configuration - Home Assistant Community (
and that seem to imply a problem with External URL plus also Version 2021.3 smartthings integration breaks · Issue #47449 · home-assistant/core · GitHub. This thread talks about rolling back to an earlier version. I don’t have an earlier version to roll back to, this is a fresh install.

Please help…

Is there anywhere I should add the URL from Nabu Casa?
The nice thing about is that the URL is automatically added when you add the SmartThings Integration. However, confirm that it is correct. I should look like
There should be no reason to try to use an earlier version as the latest version is working fine for me. I’m not sure how to help any more than that.
If the SmartThings Integration shows up in Configuration | Integrations, you could try removing it and starting over.

Hi Russell,
From the Nabu Casa site, it says this:
Remote UI
Connect to to your Home Assistant instance remotely.
Your remote url:

My URL is different from what you described. Do you think that could be the problem? I have no idea how to fix that though.
For what its worth, when I click on that link, it takes me to Home Assistant.

Have you added this to your external URL within the Configuration > General settings within Home Assistant? Also, edit your last post to remove your URL. Looks like anyone could try accessing your system. They’d need your username and password of course, but still…

To be honest, I wasn’t sure where I was meant to add that URL.
But yes, I have that in the External URL and I am still getting “Config flow could not be loaded”.

Very frustrating because I cannot fine anyone else who has a fix for this either.
Of course, it could be just that I am doing something wrong and this is what I am trying to figure out.

Free lunch for anyone who comes up with a fix…

Oh and I edited the URL in my earlier post. Bu my URL looks like its different from Russell’s; his one has whereas mine has
But that is the URL that shows up when I log in to Nabu Casa.

My URL looks like yours, so should not be the issue.
Next to check is that you’ve enabled the smart app connection in the Home Assistant cloud settings section. That’s within Home Assistant.

There is an issue here and part of it is that there are two different URLs that show up in Home Assistant. The first you can see under Configuration | Home Assistant Cloud in the Remote Control section. It will read like https://randomcharacters.ui/ and following that URL will take you to your Home Assistant Instance.
The second is found further down in the Webhooks section and will be labeled something like SmartApp (smartthings). If you click on the manage link to the right, it will show you the actual link which, as I said, reads like
These two URLs bear no resemblance to each other other than the inclusion of somewhere in the string. You need to make sure the Webhooks one is what the SmartThings Integration grabbed. If it’s the other one, it needs to be changed to the Webhooks one.

1 Like

Thank you both so much your patience in helping me.
Firstly, I believe that the Home Assistant Cloud is working; when I go to Nabu Casa and use that link (, it works, I can get to Home Assistant remotely from another PC or mobile device.

The second piece which I believe you are both referring to is in a section called Webhooks and it has entries for Local Support (Google Assistant), Mobile App and Smartthings like you said.
There is an entry there with 64 characters for Smartthings. If I click on manage, I see plus lots of text characters.
The question is; how do I know if this entry is correct?

If all this is correct; when I try integration with Smartthings, I get a message saying “config flow could not be loaded”. And this is where I am at right now, have come to a halt.

Thanks again for your patience and support.

The only recourse I can think of is to remove the SmartThings Integration and start over, very carefully following the prompts. If you recorded your Personal Access Token from SmartThings, you can reuse that. If you didn’t, you can delete the existing token and make a new one.
I don’t have any other suggestions at this point.

1 Like

When you say Remove Smartthings Integration, do you mean remove the the Webhooks section?
If I click on Manage, there is an option that says “If you no longer want to use this webhook, you can disable it.”
I could do that and start again if that is what you mean. I do have the Personal Access Token so I guess I could reuse that.

Thanks again for your help.

I was thinking more like go to Configuration | Integrations click on the “three dots” at the bottom right of the SmartThings tile and tap Delete. That should give you a fresh start at the Integration.

1 Like

Hi Russell,
That is just the thing; I don’t have a Smartthings tile. I am trying to create that integration but this is what happens;

  1. I go Configuration, Integration, Add Integration, Set up new Integration.
  2. I search for and click Smartthings things on the list and I get a pop-up that says “Error Config flow could not be loaded”.

That is the problem I am trying to get past.

One question: In Configuration, General Configuration, I have this:
External URL: https://[lots of random characters] (not sure if this is correct?)
Internal URL: http://homeassistant.local:8123

Could that be in any way related to the problem?

It’s not really related. That’s helpful in other situations where you want to call up your HA instance either locally or externally.

Thanks. It seems like I am at a dead end. I don’t have a Smartthings tile to delete.
I will keep searching and see if someone else finds something.


To confirm, this box that pops up with an error, does it contain a crazy looking link of sorts within it?
I seem to remember this happening as well. If my memory serves me correctly, that is editable and needs to include http at the front. I think this is in the troubleshooting guide.
Wouldn’t hurt to post a screenshot.

Hi, there are no links, just an error message. Please see below:


Check if you have a hidden file “config/.storage/smartthings” in your HA folder. Ctrl + h should unhide the folder in a Linux environment I believe… You may have to delete that to start fresh.
Then I’d start over from the instructions in the HA integrations section on their website. I can’t exactly remember how I got it working, but the guide is what saved me.

No one seems to have referred to the instructions yet