Cloud MQTT stopped working but not sure how to fix error

My cloud MQTT configuration stopped working for one of my HASS instances running on a raspberry pi 3b+, hassbian V0.79.3

The error on the cloud mqtt service is

2019-01-03 20:27:23: OpenSSL Error: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca 
2019-01-03 20:27:23: OpenSSL Error: error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure 
2019-01-03 20:27:23: Socket error on client <unknown>, disconnecting.

But I am not sure what is wrong in my HA configuration to cause this error. It used to work fine so I don’t know what caused it to stop working.

my MQTT confiuration only contains

  broker: !secret cloud_mqtt_broker
  username: !secret cloud_mqtt_username
  password: !secret cloud_mqtt_password
  port: !secret cloud_mqtt_ssl_port

Port is set to the ssl port for my cloud mqtt instance.

I don’t set tls_version so that should default to auto.

I think the problem is related to the error alert unknown ca but I don’t know how the certificate authority is configured in hassbian.

I don’t have anything configured in /etc/ssl on my hassbian install but I never did and this used to work so I don’t think that is what I need.

Can anyone point me in the correct direction to solve this?

I found a fix. I added

certificate: auto

to my configuration. I wasn’t seeing the error in the log that was indicated for this setting in the documentation page but it seemed related to my issue so I gave it a shot and it works now.