Cloudflared - unable to save additional hosts

When I try to add an additional host to the Cloudflared add-on I get the following error:

I have no idea how to solve this and after spending a couple of hours searching the internet, my last resort is the HA forum. Can anyone point me in the right direction? Am I the only one with this error? (hopefully not :wink: )

Ok, I think I’ve got it working now. Http didn’t work, but https does work. I do still get an error when saving, but the service does work.

And what I can’t explain is that Google Chrome and Brave both say that the domain is safe (with a valid cert), but Firefox and Edge say the opposite. Is this a Cloudflare issue?

I have solved the Edge/Firefox issue. In Cloudflare I had to select ‘Always use HTTPS’

Everything does work, but what I still can’t explain is that when I make a change in the Cloudflared add-on in HA and click on save, I get the following error:


After the restart the change has been propagated and the subdomain does work. Very strange…