CloudMQTT/ Owntracks/Hassio stopped working

Have had Owntracks/ CloudMQTT/Mosquitto working finr for the last several months. I have just noticed that the Presence indicators have stopped working in HA. The only thing I have changed of late is I set up a new router (Google Wifi Mesh) So not sure if this causing problem or not.

I have checked that Owntrack is publishing to CloudMQTT - viewed in websocketUI all Good.
I have made no change to my Mosquitto bridge (on a separate machine form HA)

tls_version tlsv1.2
connection CloudMQTT
remote_username <redacted>
remote_password <redacted>
start_type automatic
topic owntracks/# in 0

Tailing log file shows this response

1537189912: Connecting bridge CloudMQTT (
1537189974: Connecting bridge CloudMQTT (

When I send an Owntracks position, I see in cloudMQTT websocket UI, but nothing is relayed to my internal Mosquitto. AS per the log it says it is the bridge connected.

Is there anything that could off changed recently that broke this? I have had the new router for about a week, but HA is only reporting no change in presence for the last couple of days. DuckDNS/Lets encrypt is all working and can access my HA instance externally OK
Mosquitto is working fine for internal devices with HA
I have tried restarting Mosquitto and HA

1 Like

Same here. Haven’t been as thorough as you have, yet. Looking for an error message…not seeing anything at all.

My setup is simpler, as I don’t have an internal MQTT server. Hass connects to CloudMQTT directly. Worked for a few months, now nothing. I can see the owntracks postings to the CloudMQTT websocket interface, but nothing in HASS.

I did recently update the code to 0.80.1…

With the update to mosquitto stop working for me

I y’all did like me and followed the manual by setting up your owntracks client with a login of homeassistant, the new mqtt doesn’t like that. I visited each phone and changed the login to a new HA account login that I created after the recent mqtt fiasco.
All is well now.