Code-server is being accessed in an insecure context. web views, the clipboard, and other functionality may not work as expected

Hello, newby is confused. I installed HAOS and everything worked ok for few weeks but then suddenly I got message as in header. I installed a back-up that I knew for sure that is was working but with the same result. I have a laptop in the same network as a HA, so I am not trying to connect outside from my network. The one I am working is going to installed to my 86 year dad and I am going to make one to myself. For that I have a another HW ( HP prodesk 600) I tried that one also. Just installed HAOS and then VSCode and I get the same pop-up.

Could anyone give an idea what has changed to make some of my automations (Nordpool) not work as earlier?

Many thanks in advance!

/Pasi

Technically speaking this is not Home Assistant complaining, but VSCode server. It is saying it wants to run over https instead of plain http. Because http provides less protection, vscode is being more cautious, and/or it is not designed to run over http for certain things. When used locally it is indeed less of a problem, so you do not need to worry it is insecure unless you open it up to the internet that way. There’s also nothing broken with your setup.

If you have Nabu Casa you can use that to access it over https (and over the internet. But hey, it is a secure link :slight_smile: ). That way the warnings are gone. Or you can ignore it as long as you’re aware vscode may offer a little less functionality. I have yet to notice the difference.