Command_line not working on manual refresh

  - binary_sensor:
      name: Sun
      scan_interval: 600000000
      command: "/Users/server/scripts/"
      value_template: "{{ value }}"
      payload_on: "True"
      payload_off: "False"
      unique_id: sun

Any idea why this is not working since a few updates ago?

The script will not run and the state never changes. I can run the script manually and it works, but if I refresh the sensor, it doesn’t.

Interval set to 60 works as well, but that is not an option.

What do you mean by that?

You realize that 600000000 seconds means ~19 years, right?

Yes, the idea is that I can only request an update manually. However the script doesn’t run. It checks an image which is then deleted. This is never done when updating manually. It worked before though.

So by “refresh the sensor”, you mean in an automation like this, using the homeassistant.update_entity service, right?

- id: 'ce0e40ef-74f5-487b-899d-1ab66f2e0fd7'
  alias: 'Update speedtest'
  mode: restart
    - platform: time_pattern
      hours: "/3"
    - delay: "00:06:14"
    - service: homeassistant.update_entity
        entity_id: sensor.speedtest_download

You should be consistent in you wording or show the code :wink:

Exactly I am using homeassistant.update_entity. :smiley:

By running the script manually I mean the shell script outside from HA. Sorry for the confusion.

Ok. And by “a few updates”, you mean?
command_line has changed in 2023.6…

You tried to execute the service manually as well and it didn’t work, right?

Possibly, I had some issues before, but that might be unrelated.

And yes, I ran the service manually and that didn’t work. As if the script isn’t run by HA.

It’s been reported as an Issue (bug):

There’s a related bug: