Command Line Switch - Command failed


I am new to this (HASS, Debian, etc.) and I wanted to control my Milight-LEDs with Hass.
Now I downloaded an external script. Here I can control the LEDs with commands like ./milight on.

To setup this commands in HASS I installed Command Line Switch. But whenever I try to activate the switch I get these errors:
2017-10-15 08:54:50 ERROR (SyncWorker_19) [homeassistant.components.switch.command_line] Command failed: sudo ./milight_binaries/milight off

I installed HASS like it is said here:

I have no hass or homeassistant user or something like that.
The config-part for the command-line is this:

  platform: command_line
      command_on: sudo ./milight_binaries/milight on
      command_off: sudo ./milight_binaries/milight off

As a little test I created some folders (via mkdir testfolder) to see where it is created an with which user. It worked and the group and owner of the folder is root. So I can’t believe it is a permission problem.
When I run the command in the console with any user in the homeassistant folder (where the other testfolders where created) it works.

Can anyone help me or is there a “Debug-Mode” that I can see the error and not only “command failed”?

Thank you.

The first thing I would try is changing the relative path to a full path.
So, instead of
./milight_binaries/milight on

/home/pi/.homeassistant/milight_binaries on

(make sure the path is right for your installation)

I also tried that. Not working.

Can it be that HASS can’t execute the command because it runs in a container and not as an own user?