Home Assistant Community

Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f375544c990>
#378

Ah… my apologies. I don’t use Hassio, but I have a service very similar to the this component uses that I run. I think probably one was based on the other because the URLs are exactly the same. The service I use supports this. It wouldn’t be hard it add it in to this, though, since the data required to do so is all there.

0 Likes

#379

Hi,
I cannot make it work :frowning:
I change default 5000 to 5005 port, because seems 5000 its used.
When I try to access http://hassio.local:5005/broadcast_message?message= [YOUR TEXT MESSAGE] appears “This site can’t be reached”

[Info] Install/Update service client_secrets file
[Info] Start WebUI for handling oauth2
[31/Aug/2018:20:09:19] ENGINE Listening for SIGTERM.
[31/Aug/2018:20:09:19] ENGINE Listening for SIGUSR1.
[31/Aug/2018:20:09:19] ENGINE Listening for SIGHUP.
[31/Aug/2018:20:09:19] ENGINE Bus STARTING
CherryPy Checker:
The Application mounted at ‘’ has an empty config.
[31/Aug/2018:20:09:19] ENGINE Started monitor thread ‘Autoreloader’.
[31/Aug/2018:20:09:19] ENGINE Serving on http://0.0.0.0:9324
[31/Aug/2018:20:09:19] ENGINE Bus STARTED

0 Likes

#380

@AndBobsYourUncle Only Sending Broadcast in English possible?
Is it possible to set other google supported languages? If so how?
Please help

0 Likes

#381

Nobody? Please can somebody help me?

0 Likes

#382

this would be very nice to have

0 Likes

#383

Chiming in to say the Google Homes do not play the messages, but the tries get recorded in My Activity history, and the commands do work. Just no sound from Google Home.

http://192.168.1.140:5001/broadcast_message?message=broadcast testing
{“status”: “OK”} - nothing happens on Google Home

http://192.168.1.140:5001/command?message=broadcast testing
{“status”: “OK”} - nothing happens on Google Home

http://192.168.1.140:5001/broadcast_message?message=turn off all the lights
{“status”: “OK”} - all lights turn off, google Home says nothing

0 Likes

Google home tts and music
#384

Try putting the message in quotes

0 Likes

#385

I get the same thing. I’ve tried resetting Google Homes, turning off night mode, turning off IPV6, setting up the API from my wife’s account vs. mine, etc. Just doesn’t work anymore but does show status OK and shows up in history as if it worked. Stopped a couple of months back with no changes to anything on my end and hasn’t worked since.

I’ve followed every troubleshooting post in this thread and even tried another assistant package on Github. My account must be flagged or something.

Broadcasting does work fine from my Google Homes and from my phone though.

0 Likes

#386

Thanks for putting this together AndBobsYourUncle! Just got it up and running sans Docker by installing the dependencies in my Home Assistant virtualenv and adjusting the paths in run.sh.

I’m getting the same results as several people above, however: My Activity shows the broadcast taking place, but the Google Homes are silent. Commands do work for turning lights on and off. I do have IPv6 active on my network, but have other services depending on it and can’t disable it.

Going off of the link to the SmartThings thread which suggested that IPv6 might be causing some kind of location issue, I did hard-code hassio_gassistant.py to report my location. Although it’s reflected in My Activity, there’s still no broadcast.

0 Likes

#387

Out of interest, have you got it to run on system boot along with hass itself?

(I tried, but gave up)

0 Likes

#388

For those who had this working but it doesn’t now - check you actually have the add-on running!

I had a power cut, and the box rebooted. But the add-on didn’t restart…So all the calls etc worked, but nothing was generated.

0 Likes

#389

That didn’t work unfortunately.

One extra thing: when setting up and authorizing the component, the “Open web UI” link that redirected to “192.168.1.140:9324” did work, I was able to copy and paste the code. But now the link gives me browser error that the page is missing: “Unable to connect - Firefox can’t establish a connection to the server at 192.168.1.140:9324.”

And I’m unable to uninstall the addon to try reinstalling it.
UPDATE:
tried uninstalling it using ssh command line “hassio addons uninstall -name “fe49a976_google_assistant_webserver”” gave a response of:
Error decoding json invalid character '<' looking for beginning of value: <html><head><title>500 Internal Server Error</title></head><body><h1>500 Internal Server Error</h1>Server got itself in trouble</body></html>

1 Like

#390

I hadn’t since it’s not broadcasting for me, but I took a stab at it. You can launch it via systemd (and therefore should be able to enable on boot), but the trick is to make sure it uses the virtualenv where you installed the Python dependencies. I modified run.sh to explicitly use the python3 interpreter in my virtualenv.

Here’s the systemd script, and here’s the modified run.sh. Replace everything in angle brackets with the relevant info for your install.

0 Likes

#391

thanks - changed it slightly and added source /srv/homeassistant/bin/activate to run.sh to pickup the virtual env correctly.

0 Likes

#392

I’m sorry… I can’t get this to work either. Same issue as all the rest.

  • Authentication seemed to go OK (although it gave me an python error about “Wrong Credentials”)
  • Webserver is reachable, broadcasts give state “OK” and are visible in my google history.
  • https://console.developers.google.com/apis/ shows the request coming in. So there is indeed communication up to google.
  • But broadcast messages are not broadcasted. Very strange…
  • It is impossible to uninstall… Please fix that…

Hope all is well with you also. Long time no see here on the forum.

Tagging you just to be sure. AndBobsYourUncle

0 Likes

#393

For the uninstall that is broken:
That is actually a known issue
a change for fixing that is pending
(hassio supervisor issue)
https://github.com/home-assistant/hassio/pull/696 That is the PR that is going to fix that.

0 Likes

#394

It appears to have been released as part of 131 https://github.com/home-assistant/hassio/releases/tag/131

I am running |Version |131| but am still unable to uninstall with the same errors, in fact I have 2 instances of “Google Assistant Webserver” addons installed shown in Hassio, none of which uninstall either from the button or ssh command line…

0 Likes

#395

Same here… Does not uninstall

0 Likes

#396

New issue logged: https://github.com/home-assistant/hassio/issues/715

0 Likes

#397

@AndBobsYourUncle is it possible for home assistant to capture the verbal response spoken by the Google Assistant? I.e. If I ask for temperature information can I pull the spoken response in?

0 Likes