Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f20546deb08>

#385

I get the same thing. I’ve tried resetting Google Homes, turning off night mode, turning off IPV6, setting up the API from my wife’s account vs. mine, etc. Just doesn’t work anymore but does show status OK and shows up in history as if it worked. Stopped a couple of months back with no changes to anything on my end and hasn’t worked since.

I’ve followed every troubleshooting post in this thread and even tried another assistant package on Github. My account must be flagged or something.

Broadcasting does work fine from my Google Homes and from my phone though.


#386

Thanks for putting this together AndBobsYourUncle! Just got it up and running sans Docker by installing the dependencies in my Home Assistant virtualenv and adjusting the paths in run.sh.

I’m getting the same results as several people above, however: My Activity shows the broadcast taking place, but the Google Homes are silent. Commands do work for turning lights on and off. I do have IPv6 active on my network, but have other services depending on it and can’t disable it.

Going off of the link to the SmartThings thread which suggested that IPv6 might be causing some kind of location issue, I did hard-code hassio_gassistant.py to report my location. Although it’s reflected in My Activity, there’s still no broadcast.


#387

Out of interest, have you got it to run on system boot along with hass itself?

(I tried, but gave up)


#388

For those who had this working but it doesn’t now - check you actually have the add-on running!

I had a power cut, and the box rebooted. But the add-on didn’t restart…So all the calls etc worked, but nothing was generated.


#389

That didn’t work unfortunately.

One extra thing: when setting up and authorizing the component, the “Open web UI” link that redirected to “192.168.1.140:9324” did work, I was able to copy and paste the code. But now the link gives me browser error that the page is missing: “Unable to connect - Firefox can’t establish a connection to the server at 192.168.1.140:9324.”

And I’m unable to uninstall the addon to try reinstalling it.
UPDATE:
tried uninstalling it using ssh command line “hassio addons uninstall -name “fe49a976_google_assistant_webserver”” gave a response of:
Error decoding json invalid character '<' looking for beginning of value: <html><head><title>500 Internal Server Error</title></head><body><h1>500 Internal Server Error</h1>Server got itself in trouble</body></html>


#390

I hadn’t since it’s not broadcasting for me, but I took a stab at it. You can launch it via systemd (and therefore should be able to enable on boot), but the trick is to make sure it uses the virtualenv where you installed the Python dependencies. I modified run.sh to explicitly use the python3 interpreter in my virtualenv.

Here’s the systemd script, and here’s the modified run.sh. Replace everything in angle brackets with the relevant info for your install.


#391

thanks - changed it slightly and added source /srv/homeassistant/bin/activate to run.sh to pickup the virtual env correctly.


#392

I’m sorry… I can’t get this to work either. Same issue as all the rest.

  • Authentication seemed to go OK (although it gave me an python error about “Wrong Credentials”)
  • Webserver is reachable, broadcasts give state “OK” and are visible in my google history.
  • https://console.developers.google.com/apis/ shows the request coming in. So there is indeed communication up to google.
  • But broadcast messages are not broadcasted. Very strange…
  • It is impossible to uninstall… Please fix that…

Hope all is well with you also. Long time no see here on the forum.

Tagging you just to be sure. AndBobsYourUncle


#393

For the uninstall that is broken:
That is actually a known issue
a change for fixing that is pending
(hassio supervisor issue)
https://github.com/home-assistant/hassio/pull/696 That is the PR that is going to fix that.


#394

It appears to have been released as part of 131 https://github.com/home-assistant/hassio/releases/tag/131

I am running |Version |131| but am still unable to uninstall with the same errors, in fact I have 2 instances of “Google Assistant Webserver” addons installed shown in Hassio, none of which uninstall either from the button or ssh command line…


#395

Same here… Does not uninstall


#396

New issue logged: https://github.com/home-assistant/hassio/issues/715


#397

@AndBobsYourUncle is it possible for home assistant to capture the verbal response spoken by the Google Assistant? I.e. If I ask for temperature information can I pull the spoken response in?


#398

With the latest release it is possible to uninstall it. Reinstalling and trying to configure again did not work still, can’t use the add-on.

2 possible things that might be issues with my setup - can anyone please confirm if they could be the offenders:

  1. I am also using the regular Google Assistant add-on
  2. My Pi running Hassio is connected via cable not wifi

Running out of ideas, would really love to use the add-on…


#399

I was running into an issue and wanted to document it here in case anyone else is running into it

I set this up using chocomega’s instructions on post 230. I’m running Home assistant in a virtual environment (not hassio) and I want to cast music using also so this his seemed like the best solution. Follow the google documentation, make sure you have playback and recording devices plugged into your raspberrypi. Install flask, run his modified python script.

Everything seemed like it was working, could send messages to the url and get status ok but I was not hearing broadcasts and in my google activity I was getting the error “Looks like there aren’t any other speakers connected on your home network, so I can’t broadcast your message.” I resolved this issue using the “Broadcast issues” of this google documentation: https://developers.google.com/assistant/sdk/guides/library/troubleshooting

Next, i’m going to write systemd unit file to keep this bad boy running. Has anyone else run into issues trying to cast playlists from their Spotify account? Can get Spotify to play but not a personal playlist.


#400

Sorry to bump this thread but I feel this is the closest path to my goal.

I would like to be able to give Alexa a command “Alexa, ask my helper to play music on my living room chromecast”

Have “my helper” be a skill or trigger that then passes the text/command to GA Hass plugin (I currently do not own any Google home devices, just Echo Dots), which then executes (or broadcasts?) the request to Google.

My thought process is:

Alexa -> Command/Trigger -> sent to GA -> Executed.

Similar to if you asked GH directly to cast, it will. I would like to pass that verbal command (using alexa) to GA through the assistance of HA or Hassio.

I feel that @AndBobsYourUncle and @chocomega have a mixed bag of the two pieces and I am hoping we can connect them together to simply use Alexa, Google Assistant HA Plugin + GA SDK to pass these commands.

I have posted in a few discords but have not gotten responses, thus the bump of an old thread. Any feedback is appreciated.

Cheers


#401

Install went fine and broadcast works flawlessly on my RPI.

The message however does not and getting an Internal Server Error only. If I am trying another URL I get a 404 not found so it is obviously recogniizing the command. I have tried with “”, in multiple browsers and in Postman.

Any ideas what I am doing wrong?

http://IP:5000/command?message=what+time+is+it

#402

Hi, I am unable to start this addon. When installing it took a lot of time and now when I press start in less than 5 seconds it stops triyng. Nothing appears on the addon logs…

Any ideas?

I am using HASSIO with RPi and I’m at 0.80.0 version.


#403

Does anything come up in your google activity?


#404

Hi I just installed this addon, I run HA on a ubuntu vm. I have it working, it authenticated. My issue is no matter what message I put it to broadcast it will only say “this is a test”. The commands are not working either. These are the urls I am using, please let me know if there is something I am missing. thank you!!!

http://10.1.1.188:5000/broadcast_message?command?message=“whats up everybody”

http://10.1.1.188:5000/broadcast_message?command?message=[whats up everybody]

http://10.1.1.188:5000/command?message=[turn off living room lights]

I get the status ok message as well, just no action on the command and only “this is a test” on broadcast