Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f2054ce9048>

#305

If you are using port 9234 or 5000, you have to choose two other port numbers.


#306

It was port 5000… docker was using it for something else
Thanks!!!


#307

So, does the add-on work? Haha, there have been some reports from people that it wasn’t broadcasting.


#308

Not sure yet. We are trying to get my son to sleep and the WAF will take a serious hit if I dare test it now. LOL It did start up and nothing wonky in the logs.

And to answer an earlier question - running on Ubuntu 18.04


#309

Add me to the NOT working crowd :sob:


#310

I got it working in a docker on my unraid server yesterday. Super easy setup. I was always so annoyed that google tts would pause my playing music.

I found a very similar project here:https://github.com/greghesp/assistant-relay. Yours was way easy to setup with the docker file fro dockerhub…

You should definitely add the ability to send a custom string that is not a broadcast. I would imagine it would be a trivial thing to add.


#311

Great to hear it’s working for you!

The command thing is already a feature. Instead of “/broadcast_message” endpoint, use “/command” endpoint, and it’s still the “message” param.

Like this:
“/command?message=turn off the lights”


#312

Is your Google Home logged in to the same Google account that you authenticated this plugin with?

Also, have you tried restarting your Google Home?


#313

Also, see if your Google Home is on Do Not Disturb mode.

Please let me know as well if broadcasting by using the google assistant on your phone app works.


#314

Not who you were asking, but not working for me.

  • Using same google account for the relay as I set up the Google Home
  • Not on DND
  • Broadcasting works from Google Home’s, from my phone by voice, and from my phone by typing “broadcast test”
  • No errors from the relay and it shows up in my activity OK, it just doesn’t play on my devices (see a few posts back for more details)

Guessing its on the Google end and not due to your relay, but open to suggestions.


#315

Okay, so in Google Actions I believe (or somewhere in there) you configure exactly what rights you give to that particular assistant you are creating. One of those is broadcast maybe?

You’re essentially creating a project for a new google assistant and telling it what you want that assistant to be able to do.


#316

So, try this:

Go to https://console.actions.google.com
Make sure you’re here using the same google account as your google home.

Create a new project.

In the possible options, select “device registration.” It says “enable google assistant for your hardware”.

Now just fill out some stuff for the model name, etc.

For “device type”, select “auto”.

For “spec traits,” just don’t select any. Leave them all unchecked.

Now, you can download this OAuth json file to use for my add-on.

Let me know if this solves your issue.


#317

OK will try tonight. This worked great until last week and stopped for no apparent reason.


#318

Also, once you do the above steps, try unplugging your google home and reconnecting it to power after 30 seconds.


#319

I uploaded google_assistant.json to share folder, I click Open Web UI insert Authentication-key and click connect. Then I get this 500 Internal Server Error: The server encountered an unexpected condition which prevented it from fulfilling the request. Followed by a huge error report.
Any Ideas?


#320

Accidentally authenticated with incorrect token. Now I cannot connect to port 9324 to enter correct token. Also cannot uninstall addon to reinstall and start over.


#321

No go. Same result. Authenticates OK, shows up in history, but no broadcast from my devices. Reboot all Google Homes as well.


#322

In your Google Home app, you should be able to view activity.

You can see mine above. What does yours look like?


#323

That’s what I was referring to as showing up in my history. Looked like that when it was actually broadcasting and looks the same now that its not.

Its just weird since I can type “broadcast blah blah blah” in my phone and it works fine. Has to be on the Google side. Maybe I’ll try using my wife’s account since she is registered on each device too.


#324

@AndBobsYourUncle Thanks for your great addon!
Unfortunately it is not working for me after migrating to hassOS 1.7 (64bit RPi) and restoring a snapshot.
I can’t install your addon anymore, button colored red and nothing else seems to happen. I thought is was not installed because it is not listed directly within HA’s webinterface. But with the CLI it is still listed with: hassio ad list
But there I can’t do anything else then show it in the list. When I try to delete, update etc. the addon with the -name Google Assistant Webserver is not found ?? ;-(

Can you, please, help me (a noob) to get your addon working again? Any help/tip is appreciated.