Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f203fb38880>

#285

I think the issue might be with this component and not Google this time.

I tried using greghesp/assistant-relay with the same credentials, and it broadcasts without issues. In My Activity, the broadcast is coming from “Google Home” instead of “Google Assistant SDK”, but as far as I know, they use the same service calls and not the python library.


#286

This was working for me last night. Nothing changed, and no new version of this image was deployed.

Have you tried uninstalling the add on and reauthenticating it?


#287

It works for me right now (FR).


#288

Have you tried uninstalling the add on and reauthenticating it?

No dice.
Everything was working fine for me earlier this week. It just stopped working all the sudden without me touching it. I run the docker image directly, not Hass.io, so I know nothing was changed.


#289

BUMP. Sorry, but any help would be appreciated.


#290

Has this worked for anyone in the last week or so or dead for all again? It doesnt work for me right now, but really haven’t tried to troubleshoot either.


#291

Very strange. It’s currently working for me.


#292

Weird. Everything should work. I even went as far as disabling/reenabling the Google Assistant API, resetting the OAUTH crediatials, and re-doing the authentication on port 5000. It registers OK, downloads the credentials file, and logs show messages going to it, but no broadcast comes out. Any other thoughts?


#293

Stopped working for me aswell


#294

Updated the docker image by rebuilding it and it uses all the latest versions of all the python packages.

Perhaps try now and let me know if it still doesn’t work?


#295

No go. Even deleted creds and re-authorized. My Google activity shows:

Said broadcast test
Got it.
Broadcasting now.

Here is the log from Portainer.

 * Serving Flask app "hassio_gassistant" (lazy loading)

 * Environment: production

   WARNING: Do not use the development server in a production environment.

   Use a production WSGI server instead.

 * Debug mode: off

INFO:werkzeug: * Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)

DEBUG:root:None

INFO:werkzeug:192.168.30.16 - - [15/Jul/2018 18:30:35] "GET /broadcast_message?message=test HTTP/1.1" 200 -

#296

I’m not sure I am understanding this exactly. Does this replace the Google Assistant skill in the cloud component or does just provide the tts bridge to Assistant?


#297

This lets you use broadcast to send notifications to google homes. The broadcast feature has a better tts engine (tends to sound more natural than the straight tts) and it also does not stop currently playing media so music for example fades down, the notification is delivered, and then the music comes back up. You can also send basic commands like ‘turn the kitchen lights off’ but this is a little redundant as you already have HA automations and google home voice control for that.

With this relay you are creating a notify service out of the broadcast feature, so you can use it like any other notify component within HA.

Edit: And it is still working for me, btw @AndBobsYourUncle


#298

So you can run both this and the cloud / manual google assistant in tandem ?

I still want to control my lights etc and have the broadcast functionality

thanks


#299

Just wondering, if the broadcast is still working for you, whether you are using the hass.io module ? Or is this your own container instalation/setup ?


#300

I had the same issues, I uninstalled and reinstalled, and reauthorized and it now works again.


#301

Thanks @cogneato!! I was hoping that was the answer because that is exactly what I want, but I don’t want to replace the already perfectly functioning cloud component with something that seems to be having some growing pains.


#302

Yes, this add on doesn’t replace any component in the ecosystem except the tts component.

All it does is create a standalone google assistant inside the add on, and that assistant accepts text-based queries… letting you broadcast text to all your google home devices using any type of automations that would send text notifications.

The quality is not only staggeringly better than the normal google tts in home assistant, but it will not cancel music that is playing on the google home.

If you do not have google home devices, than this add on won’t be of use to you. You won’t get any broadcasts.

Also, the google home you have must be using the same google account that you use to authenticate this add on.


#303

Perfect. Exactly what I want. However, after uploading my Jon file and hitting Start, the button for grey for a sec, then red and the add on doesn’t start up. Nothing in the log in the add-on page, but will check home assistant log when I get home.


#304

What hardware are you running on?