Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f20401a4d90>

#365

Potential solution for people having issue with broadcasting (appears in the activity logs but nothing plays)

In short: disable ipv6 on your router


#366

I will have to mess with this tonight. Thanks for the post. I wonder if just disabling IPV6 in the Ubuntu VM I run Docker in would do the trick.


#367

No go for me. I disabled IPV6, rebooted everything including the cable modem, re-authenticated, and nothing. Still shows up in activity though.


#368

Im facing same issue and ipv6 solution doesn’t work


#369

The addon is not uninstalling correctly. Any ideas?

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py", line 378, in start
    resp = await self._request_handler(request)
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_app.py", line 341, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_middlewares.py", line 88, in impl
    return await handler(request)
  File "/usr/local/lib/python3.7/site-packages/hassio/api/security.py", line 56, in token_validation
    return await handler(request)
  File "/usr/local/lib/python3.7/site-packages/hassio/api/utils.py", line 32, in wrap_api
    answer = await method(api, *args, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/hassio/addons/utils.py", line 34, in wrap_check
    return await method(addon, *args, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/hassio/addons/addon.py", line 638, in uninstall
    if not await self.instance.remove():
  File "/usr/local/lib/python3.7/site-packages/hassio/utils/__init__.py", line 25, in wrap_api
    return await method(api, *args, **kwargs)
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/hassio/docker/interface.py", line 204, in _remove
    "Remove docker %s with latest and %s", self.image, self.version)
  File "/usr/local/lib/python3.7/site-packages/hassio/docker/addon.py", line 48, in version
    return super().version
  File "/usr/local/lib/python3.7/site-packages/hassio/docker/interface.py", line 45, in version
    if self._meta and LABEL_VERSION in self._meta['Config']['Labels']:
TypeError: argument of type 'NoneType' is not iterable```

#370

I have more than one Google Home, when I use the broadcast message only one of them reads out the message. Shouldn’t it be all of them? And is there possibly a way to choose which one reads out a message (via parameter e.g.?)


#371

This had stopped working for me and the fix was to turn off night mode. I had it enabled for most devices.

Edit: No you can’t choose one. A broadcast is sent to all. For specific devices you would need to use TTS instead.


#372

Im facing same problem and it’s not un-installing. thought of un-intalling and then installing again… but stuck now.


#373

I’ve had the problem with Broadcast not working - but the phrases appearing normally as if they had been broadcast in the MyActivity log.

I’ve now got it working today though (Hooray) by switching off the Night Mode setting completely. (The issue appears to be nothing to do with IPv6 in my case - and my Router (BTSmartHub) wont allow me to fiddle with IPv6 settings anyway.

Obviously this is not a complete solution as I would expect it to work when Night Mode is enabled on the device - but not during the times that Night Mode is set to be active so I have to be careful when writing automations so they don’t trigger when we are asleep!! However I suspect that’s a glitch at Google end though. Feedback sent to them to that effect.

Thanks to AndbobsyourUncle - this is great work.


#374

I have configured for both broadcasting and command mode. Broadcasting is working fine. But send command mode, I looking for the result of the command from google home mini. For example, I would like to google mini tell me the time every one hour. So for that I can add a automation in HASS by sending a google command, ‘what is the time now?’. But the output is not audible in the google home mini, whereas in the activity page, I can see that command. Am I missing anything?


#375

This emulates a Google Home device, so when you tell it to broadcast something it goes to all other devices, but when you ask if a question it responds in the emulated device, not on another device. So in your example, if you had a Google Home and a Google Home Mini and asked the Google Home what time it is, only the Google Home you asked would respond - not the Google Home Mini. The command functionality is really only useful for controlling devices that you can integrate with Google Home but not with Home Assistant.


#376

@claytonjn there is functionality to broadcast the response the “virtual google home device” received so that, when sending a command like “what time is it”, all google home devices will report the time.


#377

Interesting, I’ve been following this thread since the component was first released and don’t remember any mention of that…I must have missed it. How exactly does one take advantage of that functionality?


#378

Ah… my apologies. I don’t use Hassio, but I have a service very similar to the this component uses that I run. I think probably one was based on the other because the URLs are exactly the same. The service I use supports this. It wouldn’t be hard it add it in to this, though, since the data required to do so is all there.


#379

Hi,
I cannot make it work :frowning:
I change default 5000 to 5005 port, because seems 5000 its used.
When I try to access http://hassio.local:5005/broadcast_message?message= [YOUR TEXT MESSAGE] appears “This site can’t be reached”

[Info] Install/Update service client_secrets file
[Info] Start WebUI for handling oauth2
[31/Aug/2018:20:09:19] ENGINE Listening for SIGTERM.
[31/Aug/2018:20:09:19] ENGINE Listening for SIGUSR1.
[31/Aug/2018:20:09:19] ENGINE Listening for SIGHUP.
[31/Aug/2018:20:09:19] ENGINE Bus STARTING
CherryPy Checker:
The Application mounted at ‘’ has an empty config.
[31/Aug/2018:20:09:19] ENGINE Started monitor thread ‘Autoreloader’.
[31/Aug/2018:20:09:19] ENGINE Serving on http://0.0.0.0:9324
[31/Aug/2018:20:09:19] ENGINE Bus STARTED


#380

@AndBobsYourUncle Only Sending Broadcast in English possible?
Is it possible to set other google supported languages? If so how?
Please help


#381

Nobody? Please can somebody help me?


#382

this would be very nice to have


#383

Chiming in to say the Google Homes do not play the messages, but the tries get recorded in My Activity history, and the commands do work. Just no sound from Google Home.

http://192.168.1.140:5001/broadcast_message?message=broadcast testing
{“status”: “OK”} - nothing happens on Google Home

http://192.168.1.140:5001/command?message=broadcast testing
{“status”: “OK”} - nothing happens on Google Home

http://192.168.1.140:5001/broadcast_message?message=turn off all the lights
{“status”: “OK”} - all lights turn off, google Home says nothing


Google home tts and music
#384

Try putting the message in quotes