Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f203cfe93c8>

#447

can this be done via a HA command?


#448

I’m not sure what you mean by a HA command, but all you need to do is a simple HTTP POST (documented here: https://rithvikvibhu.github.io/GHLocalApi/#assistant-assistant-notifications-post

I’ve created a command line switch for all my assistant devices to control night mode and you should be able to do the same for DND.


#449

Thanks for the link. Do you mind sharing your code for that? Command line switches are new to me.


#450
- platform: command_line
  switches:
    dining_room_display_night_mode:
      command_off: >
        curl -H "Content-Type: application/json" -X POST -d '{"enabled":false}' http://<IP>:8008/setup/assistant/set_night_mode_params
      command_on: >
        curl -H "Content-Type: application/json" -X POST -d '{"do_not_disturb":false,"enabled":true,"led_brightness":0,"volume":0.5,"windows":[{"days":[0,1,2,3,4,5,6],"length_hours":24,"start_hour":0}]}' http://<IP>:8008/setup/assistant/set_night_mode_params
      command_state: >
        curl -X GET http://<IP>:8008/setup/eureka_info\?params\=night_mode_params
      friendly_name: "Dining Room Display - Night Mode"
      value_template: '{{ value_json.night_mode_params.enabled == true }}'

That’s what I use for my night mode switches, you’d have to adapt it for DND.


#451

thanks for that


#452

Tip

If you are using a BT Smarthub (UK) and you get the message displaying in My Activity" but no actual sound broadcast from your Google Home then try going into BT Smarthub advanced settings and then in the IPV6 options set IPv6 Address Allocation to Allocation Mode = “Stateful”.

Then reboot BT Smarthub and Google Home


#453

I was finally able to install the addon on HassOS, now that I have configured it as instructed but for some reason the message does not seems to

http://hassio.local:5000/broadcast_message?message=testmessage

I only get the below response on my browser, any suggestions?

{“status”: “OK”}


#455

I too tried this. In Google Myactivity it says your assistant needs permissions for that, maybe there’s a way to add those in Google console?


#456

Supposedly Google Assistant SDK doesn’t allow playing/casting or even routines to kind of trigger those options.


#457

Exactly wanted to do this. But seems like it’s unsupported. Were you able to find a workaround for this?


#458

My broadcasts have suddenly started to be proceeded by “broadcast from name here” then the intended message. Anyone know how to stop this as it’s spoiling the experience.


#459

You likely can’t. This is rolling out as part of the new intercom-ish broadcast features.


#460

Came here to say this! This has ruined my broadcasting! It as if Google are trying to make thing difficult sometimes lol


#461

No I wasn’t
Sorry


#462

having the same issue


#463

Bugger! This add on rules and this seriously compromises it. Someone do something smart! :slight_smile:


#464

Broadcasting/announcing the usual way “Hey Google, Broadcast/announce message” doesn’t append anything which is sort of promising that the prefix might be avoidable?


#465

Since few days the broadcast is not working. :frowning:


#466

This is a complete guess, but I’m thinking the new behavior (“Incoming broadcast from…”) is added any time the broadcast is using the assistant voice rather than a recording of the person sending the broadcast. My guess is that this is designed so that if multiple people use the broadcast feature you can tell who it was from.

If I open assistant on my phone and type “broadcast test message” the broadcast comes out “Broadcast from Clayton: test message” with the assistant voice (because I typed the message) however if I actually speak to an assistant speaker and tell it “broadcast test message” then the speakers broadcast only “test message” but in my recorded voice, so it doesn’t need to prepend “Broadcast from Clayton”.

If my guess is correct then I would assume there’s no way around it, unless Google adds an option in accessibility or something like that.


#467

You’re right I tried the same thing earlier. Although I can see the requirement for “normal” use. For our use-case It really is a shame! I’ve come to use broadcast messages in a huge amount of automations and notifications. I really don’t want to go back to TTS and the plague of problems that had for me.

Hopefully Google do add an option or an adaptation of broadcasts for the specific purpose.