Community Hass.io Add-on: IDE, based on Cloud9

hassio-repository
hassio-addon
Tags: #<Tag:0x00007fd07c8670c8> #<Tag:0x00007fd07c866b50>

#42

If you try to download a folder from the IDE, you get an error messaged stating that you must install the ZIP package. It is not allowed to add packages in HASSIO. No root access is allowed. ZIP needs to be part of the IDE add-on. Shall I post an issue in GitHub?


#43

Yes, please :blush:


#44

Hey everyone,

Mine seems to be listening on localhost rather than on the IP it is supposed to / the hostname of duckdns, log file says:

Starting standalone
Connect server listening at http://127.0.0.1:80
CDN: version standalone initialized /cloud9/build
Started '/cloud9/configs/standalone' with config 'standalone'!
Cloud9 is up and running

Any ideas why this is happening?


#45

Hello All,
I am running Hass.io on an RPI3.
I tried to install the IDE add-on and it causes a “Connection lost. Reconnection…” message to popup (I am assuming it caused and HA restart)

I have checked the “hassio s logs” and didn’t see anything there.
I also checked the “hassio ha logs” and didn’t find anything there.

Also, I did have the Configurator add-on from the Built-in Add-ons installed at one point


#46

There is nothing wrong there. Cloud9 runs on the local IP but is proxied by Nginx (in order to support SSL).


#47

I’m sorry to hear about your troubles, but I cannot pinpoint the issue based on your description.


#48

How come I cannot get it to open the Web UI then :((((


#49

Thanks, I understand there isn’t much to go on. Do you have any ideas on logs or other areas to see what might be going on?


#50

You mentioned you are using DuckDNS, so I guess you want to access it externally.
Be sure to setup port forwarding for the appropriate ports in your router.

In case you are using Lets Encrypt/SSL as well, be sure to configure it in the add-on as well.

In case you are using Lets Encrypt/SSL, modified the add-on configuration and set up the port forwarding correctly but also are including it using the iframe frontend component, be sure the frontend component is using the HTTPS URL as well.


#51

Add-on logs, Hass.io Supervisor log, Home Assistant logs


#52

That’ll teach me to work on HASS late at night and first thing in the morning… In my head, I had that because I was on my LAN I didn’t have to setup a NAT rule for it, even though i was accessing via the hassx.duckdns.org url, I added the rule in and now all working fine, thanks for the help!


#53

Someone already opened a bug and it is confirmed for ARM devices…


#54

I’m probably doing something basic wrong, but all I get in the IDE panel is a copy of my overview. Any idea why?
I am using DuckDNS, I have forwarded port 8321 in my router and I have tried restarting the addon and Hassio. I have this in my configuration.yaml;

panel_iframe:
  ide:
    title: IDE
    icon: mdi:code-braces
    url: https://mydomain.duckdns.org:8321

#55

Not sure what the answer to your problem is but I find it much more useful to use both this and Configurator directly in their own browser window/s.

This means you still have HA in it’s own window for reference and they are still there when you reboot HA to see the results of your changes… or to correct whatever you buggered up :slight_smile:


#56

Thanks. That actually makes a lot of sense.


#57

:tada: Release v0.2.0

This release is exciting, at least, for me it is. I’ve been working on this for months! And for you? Well, a couple of things…

So what did change? I’ve updated the workflows of the Community Hass.io Add-ons project. Things include:

  • Replaced CircleCI and CodeClimate. We are now using GitLab CI, backed by a couple of custom servers building and testing these add-ons.
  • All add-ons are now scanned during built and release by Clair to prevent security issues in our add-ons.
  • All add-ons are constantly scanned and monitored by Anchore.io. We will be notified immediately in case of security issues occur. (Major thanks to Anchore.io for helping us out!)
  • The add-ons repository is now entirely generated and automatically synced with all the add-ons. This ensures repositories are in sync, never forgotten and releases are almost instantly.
  • The base images that these add-ons are built on are entirely revised.
  • All add-ons have been updated to follow the Docker best practices. These are checked on every code change by GitLab CI.
  • All add-ons had maintenance. All software is updated to the latest and greatest and the documentation has been revisited.
  • There are now 2 bots in place on the GitHub project. The Add-ons Assistant is helping us out with the GitHub issues and pull requests and the AddonsBot is fully active taking care of updating code across the different GitHub Repositories.
  • We now have Edge & Beta add-ons repositories available. This allows everybody to test the latest and greatest (in case you don’t care about stability that much, or just wanna help out!)
  • I’ve removed all the PayPal, Bitcoin, … buttons. If you’d like to show your appreciation, then please, just buy me a coffee.

So that’s quite a lot, right? So what changed in this specific add-on?

Full Changelog

Added

  • Adds .yamllint configuration
  • Adds all architectures to add-on config
  • Adds Probot configuration
  • Pins down Cloud9 core version
  • Adds initial add-on README template
  • Adds Gitlab CI

Fixed

  • Fixes Markdownlint warning in License
  • Fixes hadolint warnings

Changed

  • Replaces Changelog with GitHub releases
  • Upgrades add-on base image to v1.4.1
  • Updates README
  • More efficient cloning of oh-my-zsh source
  • Updates forum link for add-on
  • Updates maintaince to 2018

Removed

  • Removes CodeClimate
  • Removes CircleCI
  • Drops support for armhf and aarch64

Yes, I’ve dropped support for armhf & aarch64, which results in this add-on is no longer supported on the Raspberry Pi.

I really did not want to, but I feel like I do not have any option left. I’ve tried many, many, many times to get it stable on these platforms, but never succeeded. The build times on these platforms is also enormous (a couple of hours), to find out afterwards it didn’t solve the problem. I’d rather ship a stable add-on.

Secondly, because of the ongoing issues on the arm based platforms, the add-on did not move forward a lot. So, with this no longer being an issue, I can continue on improving the add-on and giving it the attention it deserves.


Cloud9 - Web based IDE
#58

…but most of us are using Hass.io on a RPi3… :open_mouth: This is my main add-on because its so awesome

EDIT: so i guess i should just not update this add-on from now on…


#59

Great shame but I understand why :sob::sob: I do hope you keep looking for ways to remedy this


#60

:frowning: Sad to see this. Ah well I have other options for remote editing.


#61

my solution for now is just to not update it… the problem will come when we are forced to start from scratch when HassIO is swapped to the new underlying OS