Home Assistant Community

Compact Custom Header

#289

Not sure why on the first card, it shows the compact-custom-header at top and bottom of first column… and if I click on edit for the second one, it opens up the GUI editor for the card?

actually I do know why… somehow I had it on that column at the top and the bottom. All good!
Must have crept in with the raw editor

#290

@mayker great job, card works great!!!
just one question is there any tracker.json url for we be able to use with tracker card, custom updater?

#291

He specifically said it has been removed TEMPORARILY from the custom tracker - presumably because of the major breaking changes.

#292

ty @DavidFW1960 missed that part…

#293

David is correct, the card was removed temporarily. Also, a tracker.json file & URL is not needed for this project as it is included in custom-updater by default. Expect it to be back up there next week.

3 Likes
#294

Do I understand it correctly if I think I have to have - type: custom:compact-custom-header in every view, but only do the config in the view where I set the main_config option to true, when I’m in yaml mode?

#295

Yes, you are correct! :slight_smile:

1 Like
#296

This is great i downloaded the new version and done the config and it works really well .

Thank you @mayker @Bram_Kragten :smiley::smiley:

#297

I never was able to use the per user tab settings…
Now with latest version, gave it a try again… still can’t hide the tabs for my GF username… (I cleared cache, rebooted, etc…)

views:
  - title: Home
    icon: mdi:home-assistant
    # badges: 
      # - binary_sensor.presence_josee_lg
    cards: 
      - type: custom:compact-custom-header   
        main_config: true
        menu: show
        options: show
        voice: hide
        clock_format: 12
        exceptions:
          - conditions:
              user: jsimard
              menu: hide
            config:
              hide_tabs: 2,3,4,5,6,7,8,9,10,11,12,13   

And I added the - type: custom:compact-custom-header in each view…

Anything I’m doing wrong?

#298

Take menu: hide out of conditions, it belongs in config:

  - type: custom:compact-custom-header   
    main_config: true
    menu: show
    options: show
    voice: hide
    clock_format: 12
    exceptions:
      - conditions:
          user: jsimard
        config:
          menu: hide
          hide_tabs: 2,3,4,5,6,7,8,9,10,11,12,13

Give that a try

#299

Tried (and cleared cache, etc…), same issue, user sees all tabs and menu…

views:
  - title: Home
    icon: mdi:home-assistant
    # badges: 
      # - binary_sensor.presence_josee_lg
    cards: 
      - type: custom:compact-custom-header   
        main_config: true
        menu: show
        options: show
        voice: hide
        clock_format: 12
        exceptions:
          - conditions:
              user: jsimard
            config:
              menu: hide            
              hide_tabs: 2,3,4,5,6,7,8,9,10,11,12,13

I know it loads since the header is compacted…

#300

You’re absolutely sure that the username is correct, the user is logged in, and there are no special characters in the name?

#301

That’s what I wasn’t 100% sure…
I log in really typing in the username “jsimard” so must be it…
in the user settings, it only shows the full name and ID…

#302

Her full name contains an accent though (not the username)
2019-02-11%2011_56_42-Home%20Assistant

#303

open the sidebar menu and click the circle icon like the top right of this image:

image

It should say “You are currently logged in as” followed by the username

#304

OHHHH… so the “username” is really the full name? (because I login as “jsimard” but it shows the full name in “you are logged in as”
Just tried the full name with double quotes and it works… confusing lol…

views:
  - title: Home
    icon: mdi:home-assistant
    # badges: 
      # - binary_sensor.presence_josee_lg
    cards: 
      - type: custom:compact-custom-header   
        main_config: true
        menu: show
        options: show
        voice: hide
        clock_format: 12
        exceptions:
          - conditions:
              user: 'Josée Simard'
            config:
              menu: hide            
              hide_tabs: 1,2,3,4,5,6,7,8,9,10,11,12
#305

I only use usernames for my user’s, but I guess if you assign them full names then that’s what hass reports. Glad we figured it out.

1 Like
#306

Questions, is it possible to disable the “compact header” part without disabling everything else?
I basically just need to disable menu and tabs for some specific users but still want the standard header size…

#307

Not currently, you should add it to the feature requests on the github.

1 Like
#308

Unfortunately, I got:

SyntaxError: dynamic module import is not implemented [compact-custom-header.js:51:64](http://hassio.local:8123/local/custom-lovelace/compact-custom-header/compact-custom-header.js?v=0.0.1)

in a Firefox (ver. 65) console. In Chrome everything works OK.