Home Assistant Community

Compact Custom Header


You called @mayker :sweat_smile:

That is not true, both methods will load locally.

1 Like

Thanks @ludeeus, that’s good to know.


i’m having issues with this addon moving my cards around. i posted this in the main lovelace sub topic but have since narrowed it down to compact custom header (the issue goes away when I remove it from my ui-lovelace.yaml).

happens on all systems ive tried (desktop, mobile and tablet).

the screenshots explain my issue (see comment underneath each image)

Basically, on a fresh reload, my layout is not what I want it to be, but when I click the menu button, the layout corrects itself. Anybody have any idea why this might be happening?


Placing CCH as the last card in the view will most likely fix your issue. You could also place CCH in a vertical stack with the last card in the view if you’re still having issues.

1 Like

CCH hides itself when not in edit mode, but even while hidden the card still exists as far as lovelace is concerned. I attempt to get around this in a few ways, but in some instances the layout can get a bit funky. Most of the time this can be fixed with placement of CCH or stack cards.

1 Like

brilliant! thanks for your quick response, that did indeed fix the issue.


Many thanks to @pjv for the legacy rewrite - saved me having to throw away my wall mounted Fire 7s!


:+1: Me too. That’s why I did it.


I have been using CCH for a while now and it’s been great but I have this problem.
I am using the Hass iOS app and i have been stupid I hid the menu and now I can’t refresh the cards. Is there any way I can get it back. I used options: hide


Check out the first item in the “important notes” section of the readme.


This does not work in the iOS app.


Then you’ll either need to wait till you can get on a machine that you can edit the config with or edit storage files manually if you use storage mode (not a good idea).


Doesn’t the refresh button on the bottom of the iOS App work?


No tried that many times.


This may also be of interest:


I can edit the Lovelace files what do you suggest?


Then just remove header: false from your CCH config


You could also just use a browser on iOS to use the disable flag


Lost the header altogether now.


That doesn’t make sense unless you added header: false to your config. I would suggest logging into HA on a browser and use the disable flag in the url. Then edit your config how you like.

I misread your original post, I thought you were hiding the header with header: false, but you were just hiding the menu. In which case you just remove the “menu” config from CCH’s config options or change it to “show” instead of “hide”. Even if you couldn’t see the menu button you could still use the options button to configure the card with it’s editor or in raw config. There is a button to disable CCH completely in its editor as well.