Companion app does not like my nabu casa URL

Frustrated with DuckDNS, I decided to give a subscription to Nabu.Casa a test, and to support Home Assistant. Everything works as expected except the Home Assistant companion app for Android. I carefully enter the 46 character URL from NabuCasa and only get: “Unable to connect to Home Assistant”

Am I missing a step?

You should of course set up the cloud service in the settings (top entry), but that should be it, AFAIK.

The new companion app doesn’t need the url - I just connected locally, after configuring cloud in HA. When you go into the settings for the app choose Home Assistant Cloud and toggle it on.

Then turn off your wifi and try connecting.

What do you mean? The first thing the app asks for is “Enter the URL of your Home Assistant server.”

Nothing I enter there will connect. Not homeassistant.local, not the ip, with and without :8123, and not the 46 character URL provided by the cloud.

I can only connect to my Home Assistant on my phone through the web browser and the 46-character URL.

That’s where I got the 46-character URL:

You do have http:// or https:// in front of the url, right?

I thought I did, but I retyped the long URL with https in front and now it works.

Ok. So on your wifi network, the same one your HA is on, the local URL does not work in the local URL field? ie. http:/x.x.x.x:8123?

If so that is weird. Are you maybe still running https: on your local instance?

Don’t worry I see you have solved it.

But, thanks for the tips.