Companion app iOS only works local


I can’t connect to my server with the Companion app on my iPhone external
I can connect on local wifi

  • tried with ip and on name with DuckDNS
  • Can connect with the safari browser external

It always worked until the Companion update this week
question is the new Companion app still accepting http or has it to be https ?

getting these errors when connecting the companion app remote

2024-04-11 22:56:38.846 WARNING (MainThread) [homeassistant.components.websocket_api.http.connection] [281472874884544] from (Mozilla/5.0 (iPhone; CPU iPhone OS 17_4_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Home Assistant/2024.3 (io.robbie.HomeAssistant; build:2024.608; iOS 17.4.1) Mobile/HomeAssistant, like Safari): Disconnected: Did not receive auth message within 10 seconds
2024-04-11 22:56:39.893 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.12/site-packages/aiohttp/”, line 350, in data_received
messages, upgraded, tail = self._request_parser.feed_data(data)
File “aiohttp/_http_parser.pyx”, line 557, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: 400, message:
Invalid method encountered:

looks like deleting and reinstalling the companion app fixed the problem