Companion App not connecting to local IP

Hi all,

Here’s some background: More frequently than I like, we lose power. We have a generator to power us back up, however we lose Internet access as our provider Spectrum, does not have power redundancy.

Lack of internet access was the primary reason I wanted to move away from Smartthings and learned about Home Assistant. I absolutely love it. It works with everything, it’s reliable and allows me to automate things that don’t really need to be automated :slight_smile:

Ok, back to the issue. I subscribe to Nabu.Casa and when we have internet access everything is roses and sunshine whether we are home or away. Even when we are on generator power without internet access, the automations in Home Assistant continue to function great.

The problem is that I can’t use the app to access Home Assistant on my tablet. I can access it via the web browser on my tablet using the local IP address, but the app times out. My tablet does not have cellular access, only WiFi. WiFi is working fine, it’s just not connected to the internet. While I can access it via a browser window, I have set up a complex password which I have stored in a password manager which isn’t available without the internet, so accessing the App is far less frustrating if it’s possible.

I reviewed the Companion App settings and noticed that the “Internal Connection URL” and “Prioritize Internal URL” are both inaccessible (image below). This screen also displays that the Internal Connection URL is my Nabu Casa address rather than my local address.

Lastly, I reviewed the Home Assistant URL settings in Configuration/General and have tried setting the Local Network to Automatic and manual ( and neither seems to update the Companion App nor resolve my issue.

Not sure if it’s possible, but would love some direction if it is.



what are your Home Assistant URL settings (see config/settings/general)

I think the the app should be getting its details from there. check the settings and then try removing and reinstalling the app.

Image below. I will try uninstalling/reinstalling.

Update: Uninstalled/Reinstalled and still not working. The Companion App settings detailed above remained the same and are still not editable.

Thanks for the suggestion.

I’m not an expert on the companion app but I think I have experienced similar behavior once and I had to add the WiFi SSID’s first.

yes you need to supply Home Wifi SSID in order to define your internal URL :slight_smile: otherwise how else does the app know its an internal URL?

also uninstall and reinstall is not correct, the start fresh steps provide a better starting point as we the goal is to avoid auto back up

Thank you! That did the trick!

Thank you! That worked (adding the SSID).

Could tell me how you added the SSID?

I didn’t find it

1 Like

How can one change the SSID if the app doesn’t connect while setting it up? The app settings are not available :thinking:

1 Like

I have the same issue! This option is only available after logging in. And with local login only enabled. This isn’t possible using the external url first.


if you need to enter the SSID then first connect the app using the local IP then change the URL after you can login.

this is not an error the app can solve, but if you need to login using the local IP use that first to login as I mentioned above.

Sorry for the delayed response. I opened the AC unit, removed a cover and then reset the WiFi device. I can look into it further and provide some other details but since it has been so long, I will wait and see if its still an issue for you.