Companion App on MacBook Air M2 never uses External URL


yesterday I installed macOS companion app on my MacBook Air M2. Installation and server setup went fine.
But one thing I couldn’t correct is the detection when the App has to use the external URL.
I know it from my iPhone, iPad and my intel Mac book that detection is based on WLAN URL.

But on my Air it also has the hardware MAC address of the WLAN adapter as criteria. And that means if I am in a foreign WLAN the app won’t use the external URL.

Tried to delete the hardware address. But every time I open the window, the address is there again. Have I overseen a setting? Or what could cause this to happen?

Companion App 2023.2 on macOS 13.2.
HomeAssistant 2023.2.1 Operating System Install.
Using Nabu Casa as external URL.

Tried to install Companion app from App Store and from Github Releases. Both have same behavior.

Are you sure it is not switching to external URL when outside of your Home?

And isn’t the whole point of using Nabu Casa that you don’t have to worry about external and internal URLs etc?

Yes. Its to change between internal and external URL. When I am at home I don’t want to use the external link.
But my problem is, that the app never chooses the external URL. Because most connections go through my WLAN adapter.

I found it seems to be an error in the app. On my iPad and the other MacBook there are buttons to save or cancel. They are missing on my macbook air.

I’m experiencing the same behaviour. When outside of my home/network the app for Mac just tries to connect via the Internal URL; and never tries to connect via the External URL for Home Assistant Cloud.
Could you find a solution to this?

In my case an app udate fixed it. There was a glitch that I couldn’t change the URL settings in the app.

I tried to reinstall the app however the problem persisted.

After a few tries, the problem was solved by deleting the server; and adding it again to the companion app… not sure if some problematic config entries were still there, but in the end it is running fine now.

This issue is still an active problem.

In both cases (added as external server to an existing internal server) and adding a new server with only external address, HA does not load in the app.

When adding a new external server, I do get login screen, and I can access my external URL through browser just fine (nothing wrong there).

Unfortunately the Mac app screen remains black :frowning: