Compatible bluetooth?


Seems like this community is missing one thing most similar project have, hardware compatibility list.
At the moment i’m having trouble understanding if RPi3/4 is only board which is Bluetooth capable ?
Have few spare Intel NUCs around, but don’t have nor knowledge not time to try to make their BT radios work, beside what I’ve came upon, nobody reallly succesflly ran BT on Intel platform.

So, which board for Bluetooth, does it have to be Raspberry ?
Beside, some list would be reeeaaallly nice :slight_smile:

Bluetooth worked fine on my Rpi3. Never had an issue.

I’m now running in docker on my HP N54L Microserver running Debian Buster. It doesn’t have bluetooth so I just brought a from AliExpress, plugged it in and it worked.

This is the bluetooth dongle I got:

1 Like

Hey BT works on my NUC8i3 running Hass.IO via Docker on Ubuntu Server 18.04. LTS
So far I only use it for presence detection and a BT keyboard for local access.

@eXtatic I was using Bluetooth + Google home as extra presence detection. Actually worked quite well. Not the Google home part does not work anymore. How do you do Bluetooth presence tracking without that? I’m also running hassio via docker on NUC

I’d suggest looking at monitor which uses software (called monitor) running on other systems - usually one or more Pi Zero’s.

There’s no way to avoid Docker if you’re using the install method :wink:

a month or so actuyally started in the monitor route. Up till now did not get it working so have to revive the project.

However monitor seems a bit overkill as I dont need room detection and from my Google Home experience it worked fine if there was just 1 bluetooth ‘scanning’ device. My NUC (with BT) would in theory just do fine. So if possible, prefer not to have another device running (monitor on another RPI)

Well, I don’t use it for room detection (and I suspect I’m in the majority).

As for your NUC, it should work fine there.

I just use the bluetooth device tracker platform.

Do you remember if you had to do anything else then enable the component? setting in the NUC or install any other software on the NUC?

I get below in the logs

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/device_tracker/", line 76, in async_setup_legacy
    tracker.see, discovery_info)
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/bluetooth_tracker/", line 82, in setup_scanner
    for dev in discover_devices():
  File "/usr/src/homeassistant/homeassistant/components/bluetooth_tracker/", line 57, in discover_devices
    lookup_class=False, device_id=device_id)
  File "/usr/local/lib/python3.7/site-packages/bluetooth/", line 26, in discover_devices
    device_id = _bt.hci_get_route()
OSError: [Errno 19] No such device

Do you have bluetooth packages installed in your debian? I think I installed them in my Ubuntu.
Maybe this helps.

There quite a lot of reports with above stack trace on this forum. I think that bluetooth tracker should correctly handle the situation when “bluez” package is not installed (logs a message instead of throwing the exception).