Is it just me or is this way over complicated? I have been trying for over a week to get this set up. I can not seem to get home assistant mqtt and tasmota communicating. I am wondering if something is broken in the software. I have tried installing stand alone rpi3b, and as a vm in unraid. neither worked.

I have resorted to running my own web server with php and mysql for now. I wrote custom arduino firmware for my esp based devices to check the server for changes. It was much easier to write all this than to set up home assistant. Im not sure why it seems so difficult. I think maybe there are too many dependencies with the different software packages and instructions dont get updated.

It all depends on how much you are already prepared/what experience you have. i’ managed to get my first UI up and and running within the first hour.

That being said, start small and move on… if you need run it VM or Docker even. Do whatever. You’re gonna get 10 different options to 1 problem here and all are correctly correct.

I’ve run mine on a raspi for the last 3 years without issue other than switching from sdcard to usb flash… no real issue I couldn’t figure out myself.

take a step back… drink 2 1/2 beers… no more, no less… then begin your journey to get it working. Then you’lll have what you need.

The problem is not getting the UI up and running, that works. The problem is mosquitto and trying to figure out why nothing communicates. I see in the log the devices are connecting to the mqtt server, looks like HA is connecting also. Also looks like many of the tutorials are outdated and no one has released proper documentation for the changes. I just reinstalled again and now I get one sonoff-tasmota device that shows up on the bare unconfigured system.

sounds like progress to me…:smiley: