Component error: input_time - Integration 'input_time' not found

After watching many tutorials, I see that it’s a good idea to break up my configuriton.yaml file.

As per an tutorial, I created two (both in the config folder) i.e.

  • input_time.yaml
  • input_boolean.yaml

In the configuration file I have:
input_boolean: !include input_boolean.yaml
input_time: !include input_time.yaml

When I check the configuration I get, “Component error: input_time - Integration ‘input_time’ not found.”

I have tried deleting and recreating but I just can’t see what I am doing wrong. Even having input_time.yaml empty returns an error.

I then tried adding another file and that too also gave a similar error.

Well, there is no input_time integration, as the error message says.
You surely have no input_time:line in your original configuration.yaml

… it’s not in the right place. In which directory are your !include files?


1 Like

That’s the thing, there is :frowning:

# Configure a default setup of Home Assistant (frontend, api, etc)


  customize: !include customize.yaml

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: //ssl/privkey.pem
  ip_ban_enabled: true
  login_attempts_threshold: 5

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
input_boolean: !include input_boolean.yaml
input_time: !include input_time.yaml

# Example configuration.yaml entry for the Telegram Bot
  - platform: polling
    api_key: !secret telegram_api_key
      - !secret telegram_chat_id1

  client_id: !secret spotify_client_id
  client_secret: !secret  spotify_client_secret

  - platform: telegram
    name: hcourt
    chat_id: !secret telegram_chat_id1

  - binary_sensor:
      - name: "Downstairs"
        state: "{{ is_state('device_tracker.downstairs', 'home') }}"
        device_class: connectivity
        icon: mdi:wifi
      - name: "Upstairs"
        state: "{{ is_state('device_tracker.upstairs', 'home') }}"
        device_class: connectivity
        icon: mdi:wifi```

OK, so where did it come from? If you didn’t type it, how did you install HA?

Awesome, thanks for that… that was doing my head in.

In the configuration.yaml file

input_datetime: !include input_time.yaml