Con edison smart meter intergration


My energy provider (Con Edison) just installed a smart meter that allows me to see real-time usage. I am curious if anyone had luck getting data from their website and will like to share how?



Any updates?

Looks like this project is what you are looking for:

I’m sure this project well work as well. I’m in Orange county and set this up a few years ago on a Rpi 0 with a RTL-SDR USB dongle, sending data to my MQTT server.

1 Like

Hi @omriasta
Thank you for sharing this. I tried to use this in my Home Assistant set up. But neither via HACS nor as add-on I’m able to integrate it.
Would you mind sharing how to install it?

Thx, Sebastian

Sorry, I have not set it up at all or tried but it looks like there is a python package that could pretty easily be integrated to homeassistant as a new integration. That being said it is heavily reliant on web scraping which means that any changes to the coned website could potentially break this. Not sure it’s worth investing the time to write something like this. Also getting it to work and changing all the security settings seems like it would be too much to ask of any user. After looking into it, I decided to just go with a CT clamp device which I just ordered. It measures usage directly at the panel and communicates it internally with homeassistant for $60 it’s definitely worth it.

Which product did you go with?

Shelly EM. It should arrive next week and looks pretty simple…hopefully won’t get electrocuted when installing :wink:

1 Like

Shelly EM arrived yesterday and took about 10 minutes to install and configure. Super easy! And I’m not dead.
For some reason there is no video showing the install on a US style panel and most show the European style.
That being said if you remove the panel door and cut the main power breaker, you would connect “L” to one of the breakers(I used a less utilized 20amp single breaker). Just add the wire to whatever is already plugged in there. I connected “N” to the neutral bus (the vertical rod on either side of the panel with lots of white wires screwed in). The clamp wires are pretty clear in the diagram and it goes around the main wire going to the top of the panel, the direction is important and indicated on the clamp but pretty easy to fix if you get it wrong (it will show a negative reading and you just need to turn it around). That was it, put the panel door back on, fire up and configure as per the instructions. Home assistant auto discovered it.

1 Like

How many amps is your panel? Is it 240v? I have 200A service with two hot legs (to support both 120 and 240v loads). I see the EM has a 120A limit.

I have 200A with 2 service lines as well. You would need 2 clamps at 120A each, I wrote more here:

1 Like

Thanks! Will give it a go. Thought about SDR but looked at the meter here in Westchester county and it’s (Silverstream Networks) not on the lists. Research seems to indicate it may be encrypted as well.

Coincidence, in Westchester county as well!

1 Like

just FYI, there is a new feature request to use the smart meters of the local electricity providers, such as ConEd, to Home Assistant.
See Why buy energy monitor devices -- Use data from Smartmeter!

BTW guys I found this Home Assistant addon for ConEd/Oru. But for some reason I wasn’t able to pull data from ConEd. If you’re lucky you may able to do it.


+1 for someone looking to get data out of coned and into HA. Tried all 3 options with no luck, getting quite a few errors on both of bvlaicu’s versions and the oru community addon with 2 active users :slight_smile:


UPDATE: Through 'bvlaicu’s addon, I was able to retrieve data from ConEd at last. Even though the setup took me the entire evening, I’m pleased with how it ended out. Just a quick reminder that it’s not real time or even close to it. I noticed there’s 3 hours delay.


Congratulations and this is amazing!

I had a tough time figuring out how to find the account_uuid. Can you help me (and all of us here) figure out where you get that string? Thank you so much.


Thank you! that’s where I spent most of my time integrating this. Then I found solution here: Issue trying to find Account UUID · Issue #8 · bvlaicu/coned (

If you need more help let me know.

1 Like

@chintito4ever gratulation that you made it to work to get the data from ConEd.

I am also trying to use the add-on from bvlaicu, but I am constantly getting errors. See the logs below.
I am wondering if you had similar issues and how you solved it?
Any tip you can give?

Thx, Sebastian


EMAIL = s***********
PASSWORD = **********1f
MFA_SECRET = **********LIOF7T
ACCOUNT_UUID = 8ff0f432-7638-11eb-99d8-02001700dbdb
METER_NUMBER = 013798110
SITE = coned
MQTT_USER = mqtt_user
MQTT_PASS = **********pw
Packages list:
Package            Version  
------------------ ---------
appdirs            1.4.4    
asn1crypto         0.24.0   
certifi            2022.6.15
charset-normalizer 2.1.0    
coned              0.3.0    
cryptography       2.6.1    
entrypoints        0.3      
idna               3.3      
importlib-metadata 4.12.0   
keyring            17.1.1   
keyrings.alt       3.1.1    
paho-mqtt          1.6.1    
pip                18.1     
pycrypto           2.6.1    
pyee               8.2.2    
PyGObject          3.30.4   
pyotp              2.6.0    
pyppeteer          1.0.2    
pyxdg              0.25     
requests           2.28.1   
SecretStorage      2.3.1    
setuptools         40.8.0   
six                1.12.0   
tqdm               4.64.0   
typing-extensions  4.3.0    
urllib3            1.26.10  
websockets         10.3     
wheel              0.32.3   
zipp               3.8.1    
Starting endless loop..
[0725/] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
DevTools listening on ws://
[0725/] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
DevTools listening on ws://
Task exception was never retrieved
future: <Task finished coro=<Meter.browse() done, defined at /usr/local/lib/python3.7/dist-packages/coned/> exception=TimeoutError('Navigation Timeout Exceeded: 10000 ms exceeded.')>
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/coned/", line 143, in browse
    await page.goto('https://www.' + + '.com/en/login', {'waitUntil': 'domcontentloaded', 'timeout': 10000})
  File "/usr/local/lib/python3.7/dist-packages/pyppeteer/", line 837, in goto
    raise error
pyppeteer.errors.TimeoutError: Navigation Timeout Exceeded: 10000 ms exceeded.
Creating Meter
Calling meter.last_read()..
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/coned/", line 96, in last_read
    await self.browse()
  File "/usr/local/lib/python3.7/dist-packages/coned/", line 143, in browse
    await page.goto('https://www.' + + '.com/en/login', {'waitUntil': 'domcontentloaded', 'timeout': 10000})
  File "/usr/local/lib/python3.7/dist-packages/pyppeteer/", line 837, in goto
    raise error
pyppeteer.errors.TimeoutError: Navigation Timeout Exceeded: 10000 ms exceeded.
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
  File "", line 26, in <module>
    startTime, endTime, value, uom = asyncio.get_event_loop().run_until_complete(meter.last_read())
  File "/usr/lib/python3.7/asyncio/", line 584, in run_until_complete
    return future.result()
  File "/usr/local/lib/python3.7/dist-packages/coned/", line 118, in last_read
    raise MeterError("Error requesting meter data")
coned.meter.MeterError: Error requesting meter data
Sleeping 5 mins..