Conbee / deCONZ reliability issues. Diagnosis? Alternatives?


(Disclaimer: This is not really HA related, but I chose the HA forum as it’s one of the largest related communities and as I’m using HA for my Zigbee setup. Any better forums for this? I find my problem might be too unspecific to file an issue in the deCONZ Github. Suggestions welcome!)

For more than 2 years now I’m running Conbee + deCONZ (headless on Ubuntu) + deCONZ integration.
Apart from the complexity of the stack (having to run deCONZ service, having to use Phoscon (beta) to pair devices) I’m generally happy with the product. I find the Dresden/Conbee team responsive and am happy to support their work by paying for their hardware.

There’s just one thing that drives me nuts: Conbee and/or deCONZ being sporadically unreliable.
My symptoms:

  • After days or weeks of working just fine and not making any change to the system, the network sometimes becomes unreliable spontaneously. Usually lamps/switches/buttons react almost instantly (<1s) and reliably. But then all of a sudden, I have to push buttons 3, 4, 5 times until they react. Also switching lights from Phoscon becomes slow (multiple seconds delay) or doesn’t react at all. When that happens, I often restart deCONZ on my server. Sometimes that fixes it. Sometimes it gets even worse:
  • Often, I have to restart deCONZ multiple times until the networks works reliably and fast. Many times after a restart, buttons/switches are slow or don’t respond at all. Note that this is also in Phoscon, so HA is not the problem here. As part of debugging this, I restarted deCONZ a couple of times using the UI (not just headless), and I noticed that for a “good” restart, the network comes together relatively fast and I see a lot of green connections. But more often than not, I end up with a “bad” restart, where devices connect reaaally slowly, over multiple minutes, and sometimes not at all. In that bad state, the network is slow/unresponsive as described above. A couple of restarts later I usually end up with a “good” restart and the network works fine.

(If I have some time, I can try to record a video of this “bad restart”/“good restart” dance, so you can see for yourself.)

Note that all that happens without any configuration change, hardware change etc.
Just restarting a couple of times. That suggests to me, that it’s a software issue, as I’m not changing the hardware.

Now, that’s super annoying if your networks stops working, you need to restart (a couple of times), and part of your home isn’t working (and your wife is complaining to throw all that tech shit out the window and go back to plain lights and switches…).

For more context, my hardware setup:

  • Conbee (I).
  • Intel NUC 7I3BNK.
  • 2 m USB extension cord. No electronic device in ~1 m distance.
  • A couple of smart sockets (IKEA, OSRAM, Innr, Bitron).
  • A couple of in-wall relays for lights (Xiaomi, LED Connex, Bitron).
  • A handful each of Xiaomi climate sensors, open/close sensors, motion sensors, and remote buttons. Two IKEA buttons, too.

Software setup:

  • Ubuntu 20.04.2 LTS.
  • deCONZ headless using deconz packages.
  • I update firmware, deCONZ, HA once in a while, but I’ve had the issue for 2 years now on and off, so don’t think it’s related to updates.

Network setup:

  • Home wifi is on channel 6.
  • Zigbee is on channel 25. So no overlap with wifi.
  • I even tried different orientations of the Conbee stick. I believe the antenna is positioned at the far end of the dongle (away from the plug), and in parallel with the short edge at that far end. Positioning the dongle like this gave slightly better reception: Ξ[█ █ █ █ I] (antenna is the I at the end, I believe).
  • Generally a relatively tight and green network (when it works…).

Great guide by KennethLavrsen btw on the most common problems. I believe I did all I could from that guide already though.

Did anybody else experience this?
Any ideas to debug this?
I ran deCONZ with extended logging:
deCONZ --dbg-info=2 --dbg-zdp=1 --dbg-zcl=1 --db-aps=1 --dbg-http=1
But that’s just way too spammy to make any sense of the output.

As this changes significantly when restarting deCONZ, my hunch would be that it’s a combination of Conbee/deCONZ not being happy together after that restart. Not sure if the Conbee is acting up after some initialization from deCONZ, or if deCONZ gets confused depending on the state that the Conbee is in when starting up…
I’d even buy a new Conbee II and re-pair my whole network only to finally get rid of these reliability issues. But who knows if that makes any difference and I’m just wasting money.

If nothing helps, I’m also open to switching to completely different stack with a different dongle/gateway, if anybody can suggest a rock solid combination.

Thanks for all your suggestions!


I see a lot of people using deconz/conbee, and it seems a bit overkill to me.

I bought , plugged it in an rpi3, using the vanilla ZHA integration, and I have no problems…

1 Like

Thanks for suggesting the SMaBiT dongle! (Silicon Labs Ember 3587 chip)
I suppose this will work using just the ZHA integration (based on zigpy).
Would this be a good list to check device compatibility?

How fast is support for new devices usually added? For example, the IKEA shortcut button did require some code changes in deCONZ/Phoscon with Conbee. The team was responsive, it took some time and only works in Beta now.

Best is to check compatibility with zigpy, the library behind ZHA : GitHub - zigpy/zigpy: Library implementing a ZigBee stack

Device support is in GitHub - zigpy/zha-device-handlers: ZHA device handlers bridge the functionality gap created when manufacturers deviate from the ZCL specification, handling deviations and exceptions by parsing custom messages to and from Zigbee devices.
You create “quirks” for device not quite following the zigbee specs.

And I thought it was me… same issues here! I’ve been told its the ikea bulb and the ikea remote that are “known to have issues”. Not sure if its deconz. I can try zigbee2mqtt with a coordinator from there I suppose.

Please do post back if you found a solution or alternative platform working for you. I’ll do same if I get the time/patience to switch to something else for testing purpose @thowi

I’ve had this problem since the beginning, long before I owned any IKEA devices.
I would be surprised if it’s related to IKEA devices.

Hi there! Any update on this issue? I’m having the same problems and also am finding it really hard to find a solution on improving my stability.

What operating system are you on?
What is your your issue?

Thank you for your reply! :slight_smile:

I’m running Home Assistant OS on a Raspberry Pi 4 (8GB).

I have a Conbee 2 USB running with ZHA (currently 51 devices throughout my whole house) and sometimes lights, remotes or even my Woox Home Garden are simply not responding (having to push buttons 3,4, 5 times like in the original post). Or when I have automations to turn on the lights on motion, it simply doesn’t work sometimes.

I’m just a bit struggling with what I should try to improve the system or how to find the issue. There are a lot of posts with sort of similar problems and many things to try, but none of these posts finish with a satisfying conclusion on what actually worked.

As an example, there are many yellow and red lines in my visualisation. That’s a good observation, but now what? The connections are made by the Zigbee mesh automatically and seem to be between devices even very far away from each other, so of course they are red sometimes.

Well, sorry for my bad vibe, I’m just really having a hard time to find proper documentation or solutions for my issues.

The solution is:
Bind a Zigbee device to an specific zigbee router.
How to do that, I don’t know :blush:

Maybe via a nearby router? I didn’t test is.