ConBee II with HA on Synology DSM 7.0 (Virtual Machine)

I sure do!

After starting of add-on my Conbee disappears and is not available in Deconz. Any idea?

Hey @Tamiami, do you use the integration as well?

@Magix3D Okay again, now its weekend :slight_smile:
I used Docker for a long time with two containers for HA and Conbee. Based on issues with last DSM update I would like to change VM, Bluetooth installation is easier to install as well. My current setup is HA in VM and Conbee still in Docker container. Now I would like to implement Conbee to the HA setup as well.

If I follow the setup I can choose the Conbee stick within the settings. After the start of the add-on the stick will disapear. Means the stick is not available in Deconz interface and also in the add-on settings.

So… what is wrong or what do you need to support?


Hey @Tamiami, you actually don’t need Docker at all.
DSM natively supports USB devices with a VM, so you can just delete you docker package and select the ConBee as USB device in your VM settings.
After a restart of your DSM it should be recognized by the addon and you should be able to use the integration as well :slight_smile:

@Magix3D That is exactly what I have tried. But as mentioned several times. After start of plug-in the stick disapears. I guess something is wrong…

i have problems with Synology VMM and the conbee II stick too. I can add the stick via usb in the VMM UI to my HA install. Afterwards i can also add the stick in my HA.
But after a couple of time, my VM automaticly dismount the usb device from my HA. Anybody could fix this meanwhile?

Hi all.

yesterday I apply on my DS 220+ the last official update DSM 7.1.1-42962 Update 1.

My Homeassistant is running as virtual machine by using DSM “Virtual Machine Manager” and before the update the dongle Conbee was running inside HASSIO properly.

After the update it seems the intgration Deconz is not anymore able to see the USB port where the dongle is plugged, but within the virtual machine manager it’s properly recognized.

I tried plug/unplug, restart and other similar stuff w/o success.

Same issue here, haven’t been able to find a solution yet…

Even if apparently present into VMM and properly mounted the stick is generally not present in HA.

I can view it if before starting the VM, I force driver loading in DSM by following this guide:

Then the stick is showen, I can start Deconz add-on, but if I try to enter in Deconz it diseapper and there is no way to have it back rather than restart the entire Synology and repeat previous steps before starting the VM.

This installation was working properly since 2 years and it was started with DSM 6 and moved to DSM 7 w/o any issue…the new minor update really created a mess.

1 Like

I’m having issues too. I’m using Docker (not VM). I was using a manual driver install solution (Jadahl). I’ve had no issues until now with a USB extension cord, then a 4-port hub with both a Conbee II and Zooz stick plugged into it.

I’ve lost the Zooz stick (ttyUSB0), but not the Conbee II (ttyACM0).

I’ve had two recent changes which unfortunately were at the same time, but based on this post I’m putting the issue down to the update, not the new USB participant:

  1. I added a UPS to my setup and plugged that into the spare USB port. No issues with the UPS reporting to the NAS
  2. I updated DSM (to DSM 7.1.1-42962 Update 1) when I started up the NAS after powering it down to move the UPS into line

I found a Marius Hosting article mentioning use of a Synology community package which looks to be doing something similar to the manul driver install, but is much easier:
. Unfortunately that doesn’t resolve the issue for me either so I’m stuck as well.

I’ve tried re-running the shell script (in the article), unplugging the USB extension with the sticks on it, and switching the ports over (between the UPS and sticks). When I ‘ls tty*’ from /dev I can see the ttyACM0 (Conbee), but the ttyUSB0 is MIA.

@BeardedConti > this may be your area of expertise? Any thoughts?

@lambu76 It looks exactly the same for me. I have been using Conbee II for years, first in the Docker, later in the VMM. This morning I installed an update from Synology (DSM 7.1.1-42962 Update 2). Unfortunately, no improvement.

The Conbee II is visible in the VM and is not detected by Deconz, not even in the hardware overview. I would like to know what the root cause is, Deconz Update, Home Assistant or Synology VMM.

Hopefully there will be a solution soon, I’ve been living without Zigbee for a few days now and just realizing how dependent I am. :wink:

With today’s update of Deconz for Home Assistant and a reboot of the disk station without Conbee (later plugged in again), it works for me again as usual.

Can you confirm that?

@Mr_Holle same exact thing happened to me after updating DSM 7 to the latest version (DSM 7.1.1-42962 Update 1).

I run mine in a docker container but the Conbee2 device was not being recognized within the settings of my Virtual Machines and it was no longer found in /dev/

I tried everything to fix this, but it turns out the fix for me was to remove the usb male to female cord that was used to extend the range. Once I plugged the Conbee2 into the front of my Synology (DS920+) it showed up in VM and showed up again as /dev/ttyACM0

I’ll have to do further testing to see if it was the cable, but it’s high quality and in great condition. Its been working for months and I feel the update made it unusable. Will test further but sharing experience/fix for me so far.

Edit: format.
Edit2: Another thought could be an update to the Conbee2 firmware that made my extension cord unusable. It also was not found by my Raspberry Pi when used with an extension cord rather than being directly plugged in. Could be the cable still, so when I find another to exclude it I’ll update here

Adding another post here since I was able to dig into this further and found a good solution for my setup.

So it looks like the USB extension cord was not the issue after all. Prepare for quite the read below:

I plugged my Conbee2 into the front of my DS920+ and it was found in DSM and worked. I tried to set up my sensors and switches again but the range on the Conbee2 was not able to make connection to some sensors I had about 5 feet from my Synology. This is because it’s directly plugged into the Synology and is around all of my other devices.

I then found a 4-port usb hub. This usb hub lights up blue when I connect it to a usb slot. So I connected it to the front of my Synology and inserted my Conbee2 into it. Blue light on the usb hub turned on and Synology found the Conbee2 device (in VM settings and in /dev as ttyACM0 – note: it use to be ttyAMA0 before this issue happened).

I then connected my usb hub into my extension cord I originally was using before my Conbee2 stopped registering. It lit up blue, so I plugged my Conbee2 into my usb extension cord that was connected to the usb extender. Then it worked again (hurray!). It was now found in DSM (in VM settings and in /dev) and had a good signal to connect to my sensors since it was far away from my Synology and other devices.

When I plug my Conbee2 into the usb extension cord (without a usb hub) it does not work anymore. super odd - and a weird fix - but I hope this helps someone that is in the same situation as I was.

@dlan Thank you for your detailed description. :slight_smile: This afternoon I had again a failure of Conbee II in VMM of Synology in combination with Home Assistant. The root cause was obviously a reboot of my DS1819+. After that I spent again an hour to fix it. Now my Conbee is plugged into the USB hub with an USB extension. We’ll see how long it takes for that to stop working again. Too bad, because this worked for me for a few years without any problems. :frowning:

If this happens more often, I think I will buy a Raspberry Pi 4, so that this finally runs maintenance-free. No I joke, that would be a waste, because my Synology runs 24/7. :wink:

1 Like

Pair with the CONZ
Unlock your deCONZ gateway to register with Home Assistant.

Go to deCONZ system settings (Settings → Gateway → Advanced)
Press the “Unlock Gateway” button.

After that: Unable to link to the gateway.

not getting what you are suggesting.

can you please add some additional comments ?

I have DSM 7 on 921. I have a conbee ii connected to the Synology using a USB extension cable. I have home assistant installed in virtual manager. I had the adapter disappearing in the vm config after a HASS restart. I would then have to manually go select it in the GUI, This was pre upgrade to DSM 7, post upgrade this is very stable…Looks like the upgrade helped