ConBee II with HA on Synology DSM 7.0 (Virtual Machine)

Hey together,
I read through approx. 50 articles regarding this issue.
I have my HA set up using a VM on my Synology.
Everything works fine, whough I can’t find working way to use my ConBee II on my HA, no matter what I do.
Is there anyone who has a complete guide on how to set it up from start to finish, without any parts missing and mostly not and update from and older version, just a documentation for a fresh installation.
Thanks so much in advance.
Kind Regards

1 Like

I am using this setup for 1 or 2 years (previous with DSM 6).

What are you doing, what went wrong, where you have trouble?

I was trying to look into this and some people seem to say it might have something to do what type of USB ports the synology has and that its a USB driver issue. or maybe the usual VM issue with identifying USB. Can you detect it in these settings?
image

With VMM and these settings, you should be good to go - you just need to select USB device from drop-down list for USB device.
VMM shouldn’t require drivers for device as this should be pass-through interface and everything is done inside VM itself.
BUT there are some devices that work in a bit different way (for example Google Coral), where you first here select generic driver name, go in VM, activate device and only then does it here change name (and device has to be re-selected) to Google Coral.
With most of the normal Zigbee/Z-Wave sticks you shouldn’t need to do so (Conbee II including).

@MrReiss & @BeardedConti,

I’d say this step looks fine for my taste on my end - the same as yours.

In my logical thinking I don’t need the docker container anymore, since the ConBee is directly plugged in in the VM, so that step isn’t neccecary - is that right?

Funny thing is - if I unmount the ConBee and remount it it shows in my Supervisor:

image

I can now select the ConBee in my Deconz-Config:

Okey, just did these exact steps and now it does work.

So, for everyone struggling, at least in my case I have this setup and if u take these exact steps I can now add sensors and stuff as I please.

Setup:

  • Synology DSM918+
  • DSM-Version: 7.0.1 -42218 Update 2
  • Dresden-Elektronik Conbee II
  • Home Assistant running on Virtual Machine
  • ConBee II is not running on Docker

Installation:

  • Set up Home Assistant on a Virtual Machine (I recommend this guide by @BeardedConti)
  • Plug in your ConBee II
  • Install the Deconz-Add-on from the Store
  • Select the ConBee II in the configuration tab
  • Select the “Show in sidebar” and “Watchdog” for the Add-on
  • Start the Add-on
  • Click on Deconz on the Sidebar
  • Click on Phoscon
  • Add all the sensors and other devices such as smart plugs as needed.

I hope this helps :slight_smile:

Greetings :yum:

Hey @BeardedConti,
maybe I was a bit to quick.
The sensors can be connected, they get pulled into HA automatically, but they all appear disabled, the device itself as well as the entities:

I can manually activate them, but thjen it just says:

It also pulled the wrong names from Phoscon - that’s no issue as I can rename them, but in my old setup (which I had to reset) that worked fine.

Do you maybe know what this casuses the issue? The sensor itself works, as I can see it the Phoscon Add-on itself.

Kind regards

Update:

I had to wait quite some time - now the sensors work fine.

1 Like

Glad that it’s working :slight_smile: Not sure why they defaulted to disabled to be honest, that’s strange (if all were disabled).

Tip is also to update firmware on ConBee/RaspBee Zigbee adapter regardless of implementation used:

https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/Update-deCONZ-manually

https://flemmingss.com/how-to-update-conbee-conbee-ii-firmware-in-windows-10/

https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/Firmware-Changelog

Recommendation is to temporarily unplug and update firmware natively in barebone OS on a computer

This seemed to work! but then it has to restart the HA service, and all of a sudden i could no longer connect to the device. i even lost the device placement that you showed in the second picture. Has this happened to anyone else?

Oh im just stupid i guess. Instead of adding deCONZ integration i assumed the the Zigbee that showed up was the one to use.
image

This is not the one that can import all entities later on. So my problems seemed to be solwed!

1 Like

Glad to hear, that it works for you as well.
At first I didn’t get, that you need both, the Add-On and the Integration - kinda stupid I guess, but that’s where the documentation is lacking :smiley:

Exactly! Still there is issues with the USB if the VM och NAS reboots and you have to demount and then mount it agin for it to work. and it takes a while before all units are found again.

Well, can’t say anything 'bout that since I never shut down my NAS or VM :grin:

1 Like

USB automatic discovery is meant for native Home Assistant core components like the ZHA integration:

https://community.home-assistant.io/t/community-help-wanted-to-whitelist-all-compatible-zigbee-and-z-wave-usb-adapters-for-automatic-discovery-in-home-assistant-os/344412

ZHA integration support ConBee/RaspBee adapters nativly without the need to use deCONZ/Phoscon:

https://www.home-assistant.io/integrations/zha

https://www.home-assistant.io/integrations/zha#discovery-via-usb-or-zeroconf

I guess the idea is that most people who run deCONZ/Phoscon do so on a separate computer from the Home Assistant core instance and instead connect to deCONZ/Phoscon over the network via TCP/IP

https://www.home-assistant.io/integrations/deconz/

Just click the “IGNORE” button for the ZHA discovery and then search for deCONZ and setup yourself.

Has anyone managed to get this configuration (Synology on DSM 7, running HA on VM with Conbee 2) working with zigbee2mqtt add-on?
I’m struggling to start the add-on for the first time and I get Error while starting zigbee-herdsman every time.
I have set adapter: deconz in zigbee2mqtt config and conbee stick is visible in HA hardware.

After a few hours I found out that the default HA integration, that automatically starts when Conbee 2 is recognized, must be removed.
Everything works now.

Anybody else had problems with the Conbee stick randomly & regularly unmounting itself in the virtual server.?

1 Like

Yes, I do. Happens once a month I think.
Don’t know why… don’t know how to debug this.

Yep, I was having this issue in that about 1 in every few HA restarts I’d lose the ConBee.
I found plugging it into Windows to do a firmware update it would continually bounce between states - until you “captured it” for use.
About two weeks ago I finally cracked it, spun up Zigbee2mqtt in a Docker instance and moved all my devices over to that, removed the add-on from HA and have since restarted HA with absolutely no issues (i.e. loss of Zigbee devices) since then.

1 Like

Do you run zigbee2mqtt on the same NAS?