Conbee setup

Hello to the team,

once again i need your knowledge. Just received conbee and xiaomi aqara weather sensor but i have no idea how to configure it in home assistant running on a RPi3. I’m using duckdns and ssl as well.
If i connect it on my windows laptop i can see the conbee and go to the webapp but from RPi i have no idea what i have to do.

I have read other topics but i was more confused!! If someone can tell me the steps i have to do i would appreciate it!

1 Like

That was fast. I have seen that but still confused. For example, which IP once i put the conbee on my laptop i could check the webapp from x.x.1.5 which is my laptops IP but when i put it on RPi how can i see the webapp? How can i find the Api_key? I could find it through the webapp in windows and the integration went well but after that what?

yes, the “host” will be the IP of your laptop, since your laptop is where you’ve installed deCONZ.

The instructions for getting an API Key are on the very page I linked you to.

I think you just need to read all of the words on the Home Assistant documentation page for this device, try it, and THEN post here with any problems you have including error logs.

I want to have it on my RPi because my laptop won’t be turned on all the time, how can I reset it and try it again from RPi and make the conbee to get RPis Ip?

Sorry for bothering but is a mess in my head.

I would start by plugging it into your Raspberry Pi and following the instructions to setup the deCONZ software there.

Again, on the documentation page I linked to, the VERY FIRST heading is “Recommended Way of running deCONZ”. I would suggest doing that.

Try it, and THEN post here with any problems you have including error logs.

Please… just try it. It’s so much easier to help someone who has tried it and is getting an error than it is to say … “step 1: follow the instructions on the docs page, step 2: follow the next instruction on the docs page, step 2: follow the next instruction on the docs page”.

This would work if only you could understand how ti works. My RPi has x.x.1.9 and my computer has x.x.1.5 If i put conbee in my laptop works and connects to the sensor.

When i put conbee to RPi the ip should be x.x.1.9 correct If keeps x.x.1.5 how it will work if my laptop is closed?

Deconz is installed or i have to install it? Following this instructions i m getting an error that sudo or dpkg command not found.

Now conbee is connected on RPi, and home assistant has found it but in order to get the api key i have to go to the webapp which is not accesible. The password on the pwa/login.html doesn’t work (the delight). So i have no idea what is going on.

ANd i have read the topic youi posted before i wrote here and i have done it again.

No idea how and what is going on but it works. I can read data from the sensor. Let’s see how it goes.

Nah, i’m totally lost. when i go to

it shows the conbee with x.x.x.5 IP. If i go to this address it doesn;t show anything. In integrations card says setup error after restarting RPi.

Officialy i’m completely lost and i do not think it’s my fault as the steps are not clear at all.

Things you need to do first:

  1. Make sure that deconz is not running on your laptop
  2. Make sure that deconz is running on your rpi
1 Like

Newbie here, just need to be pointed in the right direction.

My HA is running via

I have visited:

It talks about a docker container.

I have no idea how to install the container on my

I have tried running:
docker pull marthoc/deconz

via SSH, however I get:
-bash: docker: command not found

The beginning of the document talks about running the container, but how do I install it?

There is also an area called “Configuring Raspbian for RaspBee”, not sure if I need to do this as I am running ?

Overall, unclear from the page/document on what steps need to be done from a vanilla install of


The container is a bit different from the addon. Look for the deConz addon also by marthoc

Have a look here:

That is an addon that can be installed within Hassio

1 Like

For some reason, default add-on would not install… this worked first time…

Maybe add instruction to identify usb with dmesg in cli for the noobs, otherwise, worked first time… Thanks!

I have exactly the same problem: What usename/pwd combination should be used for the web app?

Default user/pass is delight/delight

Thank you :slight_smile:

I read the above, and was a little worried, it all seemed complicated.
However, following the instructions was simple,and it worked first time.
Here’s is a account of what I did, so it may make it seem a little simpler for others.

I have a Rasberry Pi 4.
I use HA Core (2012.12.3), running in a Python Virtual Environment
I have ConBee II - Do not plug into USB untill instructed below.

Installed Docker

curl -fsSL -o
sudo sh
sudo usermod -aG docker pi

Installed the DeConz Container…

docker pull deconzcommunity/deconz:latest
sudo usermod -a -G dialout pi
sudo apt install wiringpi

Configured the serial ports

List your devices…

ls /dev > ~/devices.txt


To disable the login shell over serial and enable the serial port hardware:
	1. sudo raspi-config
	2. Select Interfacing Options
	3. Select Serial
	4. “Would you like a login shell to be accessible over serial?” Select No
	5. “Would you like the serial port hardware to be enabled?” Select Yes
	6. Exit raspi-config and reboot

and (not sure this was actually needed or did anything useful, but did it anyway…)

echo 'dtoverlay=pi3-miniuart-bt'|sudo tee -a /boot/config.txt
  • NOW plug in ConBee II to USB Port (via USB extension cable)
  • Reboot.

Find the ConBee II device

ls /dev > ~/devices2.txt
diff ~/devices.txt ~/devices2.txt

This will show the new device.
In my case it was /dev/ttyACM0

Run the container…

NOTE the line --device=/dev/ttyACM0 below - use the new device name from above.

docker run -d \
    --name=deconz \
    --restart=always \
    -p 80:80 \
    -p 443:443 \
    -v /etc/localtime:/etc/localtime:ro \
    -v /opt/deconz:/opt/deCONZ \

Connect to Phoscon

Point a web browser at Phoscon


Change to the IP address of your PI.

  • Pair your zigbee devices vi the Phoscon app.

(I didn’t bother adding groups etc in Phoscon - I did this HA later).

Connect to HA

  • Connect to Home Assistant

It reported a newly discovered integration.
Press setup, and follow the instrution to authenticate the app.

  • My Zigbee deivces appeared in HA.

ConBee II Firmware update

Having got it all running, I thought I should check the firmware.
It runs out mine was already up to date.
I discovered this by using the Windows version of Phoscon, and following these instructions.


It took me about 2 hours, from the start…

Hope this helps others, like me initially worried the comments above make is seem complex.