Config error with group: !include groups.yaml

Hi all, I have read through similar topics but have not found a working solution / explanation to this issue:

I keep getting the error below, which points to line 37 in my config file: group: !include groups.yaml

Invalid config for [automation]: required key not provided @ data['action']. Got None required key not provided @ data['trigger']. Got None. (See /config/configuration.yaml, line 37).

My groups.yaml file is empty. I have tried commenting out line 37 with the same error, and when I completely remove line 37 I get the same error pointing to line 36, which is an empty line.

Any suggestions?


check your automations, there is an automation with error.

Don’t take that line number too seriously. Home Assistant expands/merges all the !include statements in your configuration.yaml and by the time it’s done, the resulting line numbers no longer correspond to what you may think they do.

Focus on what the error message states. That’s why sheminasalam suggested you inspect your automations:

Invalid config for [automation]: required key not provided @ data[‘action’]. Got None

Thanks both! Good to know for future reference… I indeed had a WIP automation, which I removed, and the error vanished.

1 Like