Config Folder Missing After Disconnect, Lights and Router Connection Lost

Hi guys. Yesterday, some repair men came in and had to use a powertool. They ended up unplugging my router and RPi (Home Assistant OS) for about an hour. After plugging everything back in, my HA immediately started giving me issues:

  1. My router integration failed to connect.

2. My DeConz integration failed to connect. Even though I can still access it through the sidebar, the actual “Devices & Services” settings show it’s failing:
Error connecting to deCONZ gateway at
It also means I can’t control my lights through my dashboard anymore.

I ended up having to go through a hidden configuration folder to set the IP address to the correct one… Why? Why did that happen?

3. My config folder is entirely empty. Checked through the terminal.

Physically resetting the pi seemed to have solved this bit.

  1. Also this log error:
    login using all known port-ssl combinations failed.

I have tried backups and restarts but nothing’s working. I don’t see any option right now besides attempting to wipe my SD card and start from scratch. But I’m worried something like this may happen again, that something as simple as a power outage could screw up my HA to software disrepair. I feel like I shouldn’t have to go that far to deal with a little configuration issue.

Edit: Managed to restore functionality to everything but the router connection. I don’t necessarily need it but it helps with device discovery :stuck_out_tongue: