Config issue with Plex

Tried adding a plex sensor for my plex server yesterday and it broke everything. Here is my error log.

17-01-28 22:36:39 plexapi: (401) unauthorized
17-01-28 22:36:39 homeassistant.components.sensor: Error while setting up platform plex
Traceback (most recent call last):
  File "/home/hass/.homeassistant/deps/plexapi/", line 47, in _connect
    return self.query('/')
  File "/home/hass/.homeassistant/deps/plexapi/", line 110, in query
    raise BadRequest('(%s) %s' % (response.status_code, codename))
plexapi.exceptions.BadRequest: (401) unauthorized

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/helpers/", line 151, in _async_setup_platform
    entity_platform.add_entities, discovery_info
  File "/usr/lib/python3.4/asyncio/", line 388, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.4/asyncio/", line 286, in _wakeup
    value = future.result()
  File "/usr/lib/python3.4/asyncio/", line 277, in result
    raise self._exception
  File "/usr/lib/python3.4/concurrent/futures/", line 54, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/sensor/", line 52, in setup_platform
    name, plex_url, plex_user, plex_password, plex_server)])
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/sensor/", line 74, in __init__
    self._server = PlexServer(plex_url)
  File "/home/hass/.homeassistant/deps/plexapi/", line 27, in __init__
    data = self._connect()
  File "/home/hass/.homeassistant/deps/plexapi/", line 50, in _connect
    raise NotFound('No server found at: %s' % self.baseurl)
plexapi.exceptions.NotFound: No server found at:

I’ve tried taking out my plex components, nothing, tried restarting, nothing. It’s like HA is just frozen I have no idea why the log won’t update or what I can do to get it to respond.

I have the same exact error message on startup as well.
I have created my plex.conf file in my ~/.homeassistant dir with the correct information.

{“”: {“token”: “<edited…>”}}

but the logfile complains that it can’t find a plex server at
http://localhost:32400 and gives the same exact stack dump as listed above.

Hey, not sure what I did because I solved it a while back. But I remember basically just taking ever trace of Plex off my HA setup and putting it back step by step and everything just worked.