Config.txt on


I’m running hassio on a RPi B+ with this radio module

My first question is, is this supposed to work? :slight_smile:

I assume the reason that I don’t see the radio module as a device under /dev is that I’m missing this step How do I put config.txt in the root (/) of the boot partition in hassio?

I have seen …, but that is not mentioning config.txt. From … I’m not sure config.txt is read at all from the boot partition even if I knew which partition is the boot partition (like mentioned in the comments it’s also unclear to me how the boot partition is mounted).

I have tried “Import from USB” option from the web UI, but without any success. The log contains only these lines:
INFO (MainThread) [hassio.hassos] Syncing configuration from USB with HassOS.
INFO (MainThread) [] Restart local service hassos-config.service

Would the log contain also something else if the config.txt got imported?

Any pointers, help appreciated.


Welcome aboard! The boot partition where the config.txt file is located is the first FAT or Fat32 partition on the USB drive. I’ve found the easiest way to access it is to boot up to a linux OS image (either on a VM or physical system).

Are you running HassIO with the vanilla install (which uses HassOS) or did you install Ubuntu or Raspian and add the HassIO docker container?

I’m using the vanilla install HassOS and thank you for your information! It helped me find config.txt!

I mounted the SD card with HassOS again on my desktop linux PC and saw that by default the boot partition doesn’t get mounted. After mounting it manually I could locate the existing config.txt. I have added “dtoverlay=pi3-miniuart-bt” to the end of the existing config.txt file and booted RPi with it. Unfortunately, it made no difference.

I like the approach of the HassOS a lot, but maybe I should try with Raspian or Hasbian. Maybe it’s some security feature blocking it.

Btw. I had the radio module running before on a “standalone” raspberrymatic, so unless something broke in the meantime, it is working.

Recognize that with hassio, home assistant (HA) is running in a docker container, so the HA instance(container) has limited access to the host operating system and system devices. In this case, you are running HassOS. It is quite possilbe that when the HA container is started, it is not given access to the radio module.

I moved from running HA on Raspian a long time ago when a version of python was being deprecated and the process to upgrade python was not very clean. But my hardware is simpler since I access devices either via ZWave, TCPIP, or Bluetooth.

With HassIO, the maintenance has been easier, and the add-on functionality have been great.

Going back to Raspian would work. But you might generate a new post to see if anyone has built a container environment that works with your radio. There are quite a few people that use their own host OS, install docker, and then launch the HassIO container on that. This gives them the control and access to hardware that they need while gaining many of the benefits of HassIO.

Sorry for the late answer. I have thrown money at the problem and bought the homematic USB stick ( and am using that instead of the radio module. The stick worked out of the box without any modifications to HassIO etc.!

Running hassio as a docker container on for example raspbian sounds very interesting. I haven’t seen that option mentioned in the docs.

It’s there.

1 Like

OK it is also a help for my problem.
I want to get PIFace Digital2 running with a RPI3 B+ with the actual image.
I use a PC with Ubuntu to edit the sdcard with a running installation of hassio.
In the nautilus i can see hasso-data, hasso-kernel, hasso-overlay and a Datenträger (called /disc in terminal).
But i can not find config.txt to insert the line for enable the SPI to get the communication for the PiFace working.
I read here that boot should be mounted but isn’t it mounted when i see al the directories.
What is my fail, me be my knowledge in mounting is not good enough ?

Its in the boot partion. I believe this is the first partition on the SD card and is a FAT partition.

Thanks very much. But never the less, is there a way to mount this partition of the sdcard under ubuntu ?
So if I am right, there is a boot partition FAT and 3 more partitions ext on the sdcard and i only could mount the ext partition in the GUI nautilus (filebrowser) under ubuntu directly.
Until now I have set the dtparam=spi=on in the config.txt file under Windows like you suggested. The next step is to edit configuration.yaml and automation.yaml to test my results with the hardware leds on the Pi-Face Digital 2.

Linux reads Linux partitions just fine

There should be the picture from my sketch installation on sdcard under ubuntu where you see /boot and /rootfs and the config.txt with other files, but i allowed only to post 1 picture because I’m a greenhorn ;-).
This is from a sketch sdcard there I can see a boot directory and a config.txt all seems to be OK.
But when I load a Hassio sdcard it is not that what i wish to see. No boot and no config.txt, Ido not know whats my mistake. grafik file:///home/internet17/Bilder/Bildschirmfoto%20von%202019-12-01%2020-57-23.png
Thanks for your helps.

boot isn’t a directory though. It’s a partition.

Ubuntu isn’t auto-mounting the FAT partitions.
Try this:
sudo mkdir /mnt/msdos
sudo mount -t vfat /dev/sdc1 /mnt/msdos

Where sdc1 is the /boot partition of your sdcard, and msdos is the mount point.

Bingo, great, thanks to all.
There is a little hint to others, working on this problem may be a suggestion to make an add into the documentation for linux users.
A few steps more I had to do (after your help reading the manual and understanding a little bit more) :

Step1: sudo blkid
–> then i got in a list the “hassos-boot” partition block
/dev/mmcblk0p1: SEC_TYPE=“msdos” LABEL=“hassos-boot” UUID=“25BC-1A86” TYPE=“vfat” PARTLABEL=“hassos-boot” PARTUUID=“b3dd0952-733c-4c88-8cba-cab9b8b4377f”

Step 2: sudo mount -t vfat /dev/mmcblk0p1 /mnt/msdos

Now i could reach all what I want with (notification there is no automatic mount in the nautilus filebrowser):
ls /mnt/msdos
the result was, here you can see the config.txt

bcm2710-rpi-3-b.dtb bootcode.bin config.txt start.elf
bcm2710-rpi-3-b-plus.dtb boot.scr fixup.dat u-boot.bin
bcm2710-rpi-cm3.dtb cmdline.txt overlays

I hope it is helpful for other people with the same problem ( I think it is not easy for newcomers on ubuntu).

Does anybody knew some good examples (pages or blogs) for the Pi-Face Digital with hassio ?

Have a nice day and thanks for all.


There is some reference to it here, but recognize that since you are running in a container environment, things that require specific hardware access or installed software may take more work.

What do mean with work, coding time for me or for the processor caused by a lot of overhead ?
Do think it there is a better way doing automation with sensors and switches on an other platform than hassio ?
I’m coming from the embedded world, doing a lot hand by hand without the network comfort, this seems to me a great effort. But there is a greater energy consumption with networking (climate discussion).
I also want to save more energy in the house and collect more energy from the sun with hassio.
Ok enough philosophy :wink:

More work in terms of getting it to function. The link indicates it should work with Hassio, but I am always cautious about adding hardware devices to the HassIO docker environment.

I have not dealt with this device at all, but I my quick look it seems like you would be dealing with a small number of local/direct attach devices, right? So, to me that is limiting.

My turn at philosophy :slight_smile: Anything I have either communicates via IP, or Z-wave. For example, my garage door and car sensors are arduino devices that publish to MQTT where HomeAssistant can read/write. So I am not restricted by wiring runs or a number of physical connectinos.

1 Like

Many thanks!!!
I spent half of day, but you solution is excellent.