Configuration check stuck when adding Google OAuth credentials

I’m following the guide to add Google Calendar, but when I add the google info to the configuration.yaml the check is not validating the configuration anymore. It just is stuck on loading.

Anyone know what’s going on here or what I should be doing differently?

Put quotes around your password, also check your logs for errors and post them.

Around the client secret you mean? (there is client ID and client secret).
I tried but that didn’t work. (I also have HomeConnect setup with id and secret without quotes. That works).

No log entries

passwords in yaml require quotes if you have special characters in the pw itself. This will vary pw to pw. The quotes need to be around the password in secrets not in the extraction where !secret is used.

the secret only consists out of numbers and letters. still tried different types of quotes, also for the client_id, but can’t get it to work.

If I use the id and secret values with another mapping key (used the existing one for home_connect), it does validate. So it seems to not want to validate the 'google: ’ part?

can you post your configuration for this entire setup? Also, which integration is this

Following this: Google Calendar Event - Home Assistant

So I’m adding this to configuration.yaml:

  client_id: YOUR_CLIENT_ID
  client_secret: YOUR_CLIENT_SECRET

I also have this in the configuration which is working just fine.

  client_id: YOUR_CLIENT_ID
  client_secret: YOUR_CLIENT_SECRET

so it’s not the formatting of text I think, it’s the ‘google:’ part.
Not sure if it is trying to authenticate which is failing in the background or something like that?

run a config check through SSH and see what it says

It takes a couple of minutes and then just says “command completed successfully”

since this seemed ok, I tried to restart HA (from the user interface). That also doesn’t work right now. the restart button turns green for a bit and then normal again :wink:

Restart from ssh then

thanks, seems to be working after the restart. Now it’s checking the config again as well.

yep, seems like you had a supervisor to core communication issue