Configuration of FIBARO RGBW Controller


I’m having trouble configuring or adjusting the FIBARO System FGRGBWM441 RGBW Controller and its RGBW Led strip. The led strip has 4 leds (Red, Green, Blue, White). Each colour is shown as a switch in Home-Assistant.

But I dont know how to adjust it to get the colour i want, if I switch it on via the main switch (next to the name) it turns on all the leds, when i turn on one colour it shows that specific colour. But i cant mix it. Ideally I would like a switch which sets the colour I would like.

I have set the parameters of the Controller to following
1 = ALL ON active/ ALL OFF active
8 = MODE 2 - Constant Time (RGB/RGBW only…)
11 = 67
14 = 8738 (momentary, normal mode)
Rest of the parameters has the default values.

For the moment I don’t have anything connected to the inputs but I would like to have switch connected, that controlls manual on/off

Anybody know how a FIBARO RGBW Controller works?

I’m with it but at the moment I can’t help you.

When you have time please give me some help about the Fibaro RGBW Controller.

BR, Fredrik

Ok what do you need? Now i’ve it working right.

As I wrote above, I would like to be able to control the on/off of the LED-strip from one switch/button, SW
And also to be able to control the colur of the LED-strip in a simple way.


For control the led strip with switch you have to put it from the analog outputs to the neutral wire after the 12/24v VDC Adapter. Then, with one push the led strip will light and if you keep pushed the brightness will change.


I only have one switch. I connected all inputs, IN1-IN4 to that one.
Will that work?
Also what does parameter 1 ? (ALL ON active/ALL OFF active)


But what do you want to control with that switch?

For every channel you should have a switch. It depends what do you want to manage.

Okay, this is what I want to achive.
The LED-strip should both be controlled from one switch on/off, brightness (keep pressed) or from the HA frontend.
The color of the RGBW LED-strip should in the first hand be controlled from the HA fronted by one wheel or something easy controlled, i.e when the LED-strip is turned of it should remember this color. Next time when it is turned on it should have the same color as last time.
If it is possible I also would like to contol the color from a second switch, i.e if the switch is pressed the LED-strip should walk through all the colors and when the switched is released the shining color should be selected.
Did you understand ?


Yeap. To do all that things first you’ve to connect de Fibaro RGBW to zwave network of Hone assistant.

Then, home assistant will detect some entities that will control the channel or power.

Hi fran_blade,
Yes I already have my Fibaro RGBW Controller connected to the z-wave network.
I can see it and I have several switches in the HA frontend, see figure
But how do I configure the Fibaro RGBW Controller, parameters to get the right performance as I want.



Just you’ve to put the wires to switches correctly and that’s all I think.

Doesn’t it work like that ?

Because I see that you’ve hide unnecessary entities and that’s perfect.

Did anyone figure this out, I’ve just installed a Fibaro RGBW controller and I have 6 (six) switches, including the red, green, blue and white channels. However I’m unable to set parameters that either allow for the unit to be controlled by a single momentary switch or use/set any arbitrary RGB or HS colour.

I have tried a few combinations, but there are too many to try them all.

I have tried param nr14 set to (default) 4368 and single input mode 8738.

Would love to see this working better than is currently does, any help really appreciated.

Any additional

I have the same problem and I hade not solved it yet.
This problem has been paused for me, but I’m really interested to find a solution for it.
If you solved the problem, please let me know.


Did you solve this problem?
I have the very same problem and I’m stuck with it…
Thank you Fredrik!

No I have not solved this problem yet.
I have had other problem, but I really would like to found a solution to this problem.
Please let me know if you found a solution.


I am also interested in a solution to control my LED via Fibaro RGBW - anyone found a solution?

Hi, I solved with using MQTT:


# Z-Wave
  usb_path: /dev/ttyACM0
  device_config: !include zwave_device_config.yaml


# Light
  - platform: mqtt
    schema: json
    name: rgbw_led
    brightness: true
    rgb: true
    command_topic: "dummy"
    optimistic: true
    white_value: true


- alias: "Turn ON RGBW LED"
    platform: state
    entity_id: light.rgbw_led
    condition: state
    entity_id: light.rgbw_led
    state: 'on'
    - service: light.turn_on
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_2
        brightness: "{{ (states.light.rgbw_led.attributes.rgb_color[0] * (states.light.rgbw_led.attributes.brightness / 255)) | int  }}"
    - service: light.turn_on
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_3
        brightness: "{{ (states.light.rgbw_led.attributes.rgb_color[1] * (states.light.rgbw_led.attributes.brightness / 255)) | int  }}"
    - service: light.turn_on
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_4
        brightness: "{{ (states.light.rgbw_led.attributes.rgb_color[2] * (states.light.rgbw_led.attributes.brightness / 255)) | int  }}"
    - service: light.turn_on
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_5
        brightness: "{{ (states.light.rgbw_led.attributes.white_value * (states.light.rgbw_led.attributes.brightness / 255)) | int  }}"      

- alias: "Turn OFF RGBW LED"
    - platform: state
      entity_id: light.rgbw_led
      to: 'off'
    - service: light.turn_off
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_2
    - service: light.turn_off
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_3
    - service: light.turn_off
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_4
    - service: light.turn_off
      entity_id: light.fibaro_system_fgrgbwm441_rgbw_controller_level_5

It works.

Anyway, I recently reinstalled my Home Assistant controller and realised that now Fibaro RGBW Controller is automatically recognised and configured.

Let’s try!

Hi all, I’m having some issues with my RGBW as well

Everything works well if I control via HA or Alexa. However the swicth on the wall (momentary single switch) which is supports to turn on and off seems to turn on the white and blue channels and then off only the white channel (i think, it’s quite odd…)

What’s really odd is that the press of the button doesn’t seem to send any state change to HA at all, so I can’t take any action on that press either…

Bit lost how to fix it so wondering if anyone has any ideas!?