Configuration.yaml file location on ubuntu in virtual environment

With apologies for what should be an easy answer, I’m completely stumped and haven’t been able to make heads or tails of it. I installed hassio on a virtual environment on an Intel NUC running 16.04.

Hassio starts up and I can get to the web interface. The info page shows the configuration directory as “/config”. Normally, on my RPI, I’d be able to find it as part of the home directory. It’s not there on ubuntu. I do a search through the GUI for it and nothing is found. I’ve looked at ~/.homeassistant and a ton of other iterations, but nothing is coming up. I try to cd through what should be the directories but no luck.

Can someone help with what I’m sure is such an obvious answer?

Check for it off the root system of the VM, ssh or putty into your VM and type cd /config

If not there, become su and type find / -name config

in Hassio, install the samba addin and then in explorer you will be able to go to \hassio and you will see the config and a few other folders. Docker hides all this stuff from you in ssh.

1 Like


You installed 2 different versions?

Hassio runs in docker.

Home Assistant installed manually via python and virtual environment runs in a python virtual environment.

Which option did you go with?

@concord This worked. Thank you. It was sitting in /usr/share/hassio and I never would have thought to look there. Much appreciated.

@DavidFW1960 Good point. I was making the move from an RPI to a NUC and hadn’t migrated the snapshot yet which meant that no samba share had been set up. Cart before the horse on my end.

I installed in a virtual machine, at least according to the directions on the page that I linked to:

Alternative: install on generic Linux server
For advanced users, it is also possible to try on your Linux server or inside a virtual machine. To do so, run the following command as root: [insert command]

So you installed a virtual machine just for hassio? I’m kind of confused about your setup.

Is the NUC running Windows?

The NUC is running Ubuntu server. I was struggling to make heads or tails of Docker and wanted to use Hassio, so I installed it according to the directions here:

(bottom of page). There’s a distinct possibility that I did this incorrectly or inefficiently. I’m technically minded but maybe not enough to make docker happen. I wanted to use Hassio but didn’t want to image the entire drive.

I’m certainly open to suggestions. I really tried to get to the bottom of docker but it just was too terse for me.

Ok. If you just ran that script, you’re running docker.

Just wanted to make sure you didn’t make a VM and were having issues with a NAT type misconfiguration

Oh! I had no idea that meant that it installed in docker. The documentation could have been a bit clearer. Much appreciated.

Great thread. I installed Home Assistant on Ubuntu Server in VirtualBox on my Windows dev machine as per this excellent instructional video but I was stumped as to how to install Floorplan. Couldn’t find anywhere else on the web that stated /usr/share/hassio/ would be the place to look for the directory to install to. Thanks @Litrecola, you saved me from having to PUTTY into my VM.

Thanks for the tip. Samba is installed but I go to \hassio (I changed the netbios name to hassioha3) or \hassioha3 Windows explorer times out. Any other suggestions? Or is there a way to look up the docker host IP address directly? I’m new to docker.

Installed hassio on generic linux server u16.04 and I can see the hassio config folder/files via putty, ssh’ing into the server.

Any other thoughts? Thanks!

Edit - figured it out.
Make sure in the samba add-on that you add the interface, in my case it was “ens160”. In ssh, command: ifconfig Look for the interface that matches the host linux machine (not the docker container). Reboot the addon and be a little patient. 5 minute later and it works.

sudo find . -name “configuration.yaml”