Configuration.yaml root only with linux deploy and pyton install

android
Tags: #<Tag:0x00007f1b97261b50>

#1

Hello,
i start my project made of xiaomi, sonoff, hue and somfy devices.
For the moment i try to choose a plateform.
I got a pi zero w but i don’t trust in sd writing.
So I look for recycling an old android device. A tablette (acer a500) or a TV box(mxIII plus).
I first test a500, and would like to keep android.
I search for a way to lunch docker but I fall cause of too old kernel.
So I installed a debian with linux deploy, then python and homeassitant.
It’s functional but i got 2 problems of root acces :
1/ I can’t auto start it with “services”. maybe this way https://www.home-assistant.io/docs/autostart/init.d/ ? but starting HA in daemon give me an error
2/ I can’t edit configuration.yaml with an external editor like winscp (scp or sftp). I just made a test (adding xiaomi gateway) in sudo nano via ssh. test is working so acces are ok but only in root. i tried to start HA with - config home user path but same result.
I installed HA in python virtual environement https://www.home-assistant.io/docs/installation/virtualenv/
An other issue is bluetooth acces but i give up this by purchasing a xiaomi BT/Wifi lamp gateway…
Could you help me ? Sorry for my english …


#2

If its a later version of debian (jessie or later) then it will need the systemd autostart procedure. See https://www.home-assistant.io/docs/autostart/systemd/

Its difficult to help without knowing what user you started HA as, and the current permission of the configuration.yaml file.


#3

Thank you for your help !

I tried but got an issue, i will try again an post error

I have to start it with sudo … do you think i can change permission with sudo chmod ?

Do you need a “ls -l” in the home assistant directory ?


#4

There is something wrong if you are starting HA with sudo, but perhaps you meant that you are starting the editor with sudo?

Yes, that should work.


#5

I confirm i have to start HA with sudo i will post error tonight. thank you again

Edit & correction :slight_smile:
I have to use sudo to modify config but i can start HA without so i remove conf and it recreate it with user permission. So i can edit it from windows remote editor ! perfect ! Thank you.

For autostart with systemd i got this error :

[email protected]:/etc/systemd/system$ cat home-assistant\@homeassistant.service
[Unit]
Description=Home Assistant
After=network-online.target

[Service]
Type=simple
User=%i
ExecStart=/home/homeassistant/homeassistant/bin/hass -c "/home/homeassistant/homeassistant"

[Install]
WantedBy=multi-user.target
[email protected]:/etc/systemd/system$ sudo systemctl start [email protected]
Running in chroot, ignoring request.

Any idea ? Is it because of linux deploy that use chroot ?