Configurator add on installation not working

Tags: #<Tag:0x00007f73ac3ca150>

Hi,

I followed to instructions to install the configurator add on. However, when I reboot and open using the button on the left panel, I just get a spinning wheel.

I also tried to follow the documentation to manually install configurator but wasn’t able to locate the needed files.

I am using a Windows host with VirtualBox running ubuntu server for HA. Is there a different set of instructions I need to follow in this case to get configurator up and running.

Editing on ubuntu server without copy-paste support from the host is making everything 10x harder. Getting front editor for config files would make life so much easier.

Sorry if this has been addressed already, but I couldn’t find any forums addressing this specific issue.

I had exactly the same problem last week. Ended up removing that addon and adding it back again. That fixed it.

No luck for me.

Logs says:
[23:18:26] INFO: Add-on running
nginx: [alert] detected a LuaJIT version which is not OpenResty’s; many optimizations will be disabled and performance will be compromised
nginx: [error] lua_load_resty_core failed to load the resty.core module from https://github.com/openresty/lua-resty-core; ensure you are using an OpenResty release from https://openresty.org/en/download.html (rc: 2, reason: module ‘resty.core’ not found:
no field package.preload[‘resty.core’]
no file ‘./resty/core.lua’
no file ‘/usr/share/luajit-2.1.0-beta3/resty/core.lua’
no file ‘/usr/local/share/lua/5.1/resty/core.lua’
no file ‘/usr/local/share/lua/5.1/resty/core/init.lua’
no file ‘/usr/share/lua/5.1/resty/core.lua’
no file ‘/usr/share/lua/5.1/resty/core/init.lua’
no file ‘/usr/share/lua/common/resty/core.lua’
no file ‘/usr/share/lua/common/resty/core/init.lua’
no file ‘./resty/core.so’
no file ‘/usr/local/lib/lua/5.1/resty/core.so’
no file ‘/usr/lib/lua/5.1/resty/core.so’
no file ‘/usr/local/lib/lua/5.1/loadall.so’
no file ‘./resty.so’
no file ‘/usr/local/lib/lua/5.1/resty.so’
no file ‘/usr/lib/lua/5.1/resty.so’
no file ‘/usr/local/lib/lua/5.1/loadall.so’)
2019/08/27 23:18:26 [notice] 21#21: using the “epoll” event method
2019/08/27 23:18:26 [notice] 21#21: nginx/1.14.2
2019/08/27 23:18:26 [notice] 21#21: OS: Linux 5.0.0-25-generic
2019/08/27 23:18:26 [notice] 21#21: getrlimit(RLIMIT_NOFILE): 1048576:1048576
2019/08/27 23:18:26 [notice] 21#21: start worker processes
2019/08/27 23:18:26 [notice] 21#21: start worker process 29
INFO:2019-08-27 23:18:27,040:hass_configurator.configurator:Starting server
INFO:2019-08-27 23:18:27,041:hass_configurator.configurator:Listening on:

Not sure what the solution is though

What settings do you have for the addon? My settings are all default except dirs_first is true…

Hmm, default. I tired t set dirs_first is true, but no difference.

The spinning wheel did go away, now I just have a blank screen.

Update: it has automatically started to work now. The only thing I did was write a couple of automation in the meantime…maybe that caused some of the config files to reload.

@DavidFW1960 Thank you so much for your recommendations. Spent hours trying to get this to work.

1 Like