Configurator add-on not starting

I’ve had the configurator add-on installed and working in the past, but recently (I’m not sure if it was due to a hassio update) my configurator add-on won’t start. It installs and allowed me to save the config parameters, but when I hit start the circle spins for a few seconds over “start” and nothing happens. There’s nothing in the add-on log or the hassio log.

Any ideas?

Do you have some sort of Ad-Blocking extension enabled? The configurator loads external content within iframes, and they contain scripts which typically are blocked by such extensions.

I’ve tried on three different computers with ad block turned off, two different browsers, and on my phone. No luck.

I just noticed this error in my log

18-05-19 20:20:04 ERROR (SyncWorker_6) [hassio.docker] Can’t start addon_core_configurator: 500 Server Error: Internal Server Error (“endpoint with name addon_core_configurator already exists in network hassio”)

If anyone knows how to fix this I would greatly appreciate it!

Never heard of that error before. I assume you have tried to remove and install the addon again? Dependen on which version gaps you have jumped while upgrading something like that could have happened if you have skipped intermediate version that might have migrated the old addon to whatever the latest version requires. But that’s just a guess since I don’t use hassio myself.

Interesting. I actually did skip about 3 maybe 4 versions. I have tried uninstalling and reinstalling with various server reboots mixed in multiple times. No luck. I was able to get an older version of the could 9 ide working for now, but I really liked the configurator. I’m running on a pi 2 right now and have been meaning to migrate over to a pi 3 so maybe a reinstall on the 3 will fix my issues.

Thanks for taking a look.

Did you ever find the cause of this issue? I am running into the same issue… there’s not that many text editors that support Ingress yet so I am unable to edit my configuration remotely without going thru the hassle of using NGINX or opening ports.

I am gonna do a host reboot and pray that it works… it suddently stopped working. Maybe something in my configuration messed it up.


Guess what? That did the trick! :slight_smile: