Configurator Not Loading - hassio.local’s server IP address could not be found

I installed DuckDNS and am accessing my home assistant from a https:// I use Configurator to access my configuration.yaml but all of a sudden it is not loading and displaying the following: hassio.local’s server IP address could not be found.

I used ftp filezilla to edit the configuration.yaml before as home assistant wouldn’t load (had to remove some problematic customization text). Since then I’ve not only been unable to access Configurator but been unable to access hassio from putty or filezilla.

I can still use the frontend

1 Like

I’m having the same issue. It was working yesterday, and today it is timing out. The only difference from yesterday and today is that my local IP changed. I tried updating configurator and restarted the service. I also tried rebooting the Pi to no success.

As @sphirst mentioned, I am also able to use every other aspect of Home Assistant. My logs also do not show any errors, both Configurator’s logs or Home Assistant’s logs.

Any guidance on how to troubleshoot this?

I’m still curious on how to better troubleshoot this in the future but on a whim I decided to try to switch my wifi band from 5Ghz to 2.4Ghz and this brought configurator back.

I now have this problem. How is hassio.local mapped to my local ip? Can’t see how to define this on my router’s DNS. :frowning:

It’s called mDNS or Bonjour. It’s broadcasting it’s name out to your network.

OK. Makes sense, but why might it not be working when I try and use it? My laptop has VPN installed but it doesn’t seem to work even when I turn that off. I’ve had a look in my router’s log but nothing interesting in there. Any chance you can give me some hints as to where to look? I’m no expert but know my way around Linux basics although I’m a newbie with HAssIO. Thanks.

Because your router or some of your devices may not support it.

If it doesn’t work, look through your router options regarding multicast, or bonjour, or mDNS. Otherwise, your router may simply not support it. It honestly doesn’t matter if it does or not though, as you can use an IP address.

OK, fair enough. I do need to get past the “Policy Not Fulfilled” with the IP address though when accessing remotely (VPN). I can see that there is an old solution but the format of the configuration.yaml file has changed since that answer (and I’m still a newbie at this) so are there any docs giving all of the available options for .yaml files? I assume it needs to be something like this.

192.168.1.XX/24 <- Is this one for Docker stuff?

Again, pointing me at online docs is my preferred answer. :slight_smile:

Pretty sure that is an add-on message, and not a Home Assistant message. Adjust your add-on settings.


Everything depends on what component you are trying to configure. It’s all in the documentation pages.

OK. Getting through it all slowly. Will try being more patient. Not easy…