Configurator not working after latest update! PLEASE HELP!

Hi people, first timer here! Been using Hassio for few months and generally ok with finding my way through the config forest and other parts of yaml woods. Came across a major problem after the latest update, where the config addon (also updated to the latest version) is no longer working (i.e not opening the webUI and all config fields getting empty - when filled out and saved, they default to the empty state straight away after any other button is pressed (i.e Open WebUI etc)). Any thoughts and assistance will be GREATLY appreciated!!!

I have same issue. The config setup is empty and can not be saved. I restored version 2.1 from snapshot and it is working now.

I have posted a short summary on what has happened and how to act accordingly here: Simplistic configuration UI

Thanks so much for your reply! Unfortunately, when I try to do as the video advises, i get the “401: Unauthorized” error. Would anyone know how to fix this? Thank You!!!

I get the same “401: Unauthorized” too… and it is happens quite randomly.

doesn’t matter if I go via the “open web ui” button in the add-on menu, from my panel_iframe or just from a bookmark.

The only thing that’s unlocks it for me and everything starts to work again for a while is to first access the configurator via the http://192…/hassio/ingress/core_configurator url and then the http://192…/api/hassio_ingress/1d7wVJ…Y/ url works again. :stuck_out_tongue:

Configurator 3.1
HassOS 2.11 / 155
HA 0.91.2 (32 bit)
Raspberry PI 3b+

Same problem to me only difference i’m using 64 bit version on raspberry3b+ HA 0.9.2 and hassOS 2.11 configurator 3.1 and using a panel on iframe http://HAip:3218 like before the bug, but I need open webUi before start to working

There is an issue.

Currently it can work with:

  - name: hassio-main
    sidebar_title: Configurator
    sidebar_icon: hass:settings
    js_url: /api/hassio/app/entrypoint.js
    url_path: configurator
    embed_iframe: true
    require_admin: true
      ingress: core_configurator

For some reason this does not work for me on Firefox, I just get a dark page for any of the updated plug-ins even when using the “Open Web UI” button on the add-on page. On Chrome, it’s fine.

Just an update from the official blog:

For the upcoming Home Assistant 0.92 release, we will be adding support to add links to your add-ons to the Home Assistant sidebar via a toggle on the add-on details page. The link will open the add-on Ingress interface, embedding the add-on in the Home Assistant UI. This will make it look and feel like a single system.

After upgrading the add-on, my panel_iframe doesn’t work anymore.
This is related to the question above. Once you enable direct access again, your iFrame panel will start working again. Until the automated panel integration lands in 0.92, you can also manually add a panel that points at Ingress.

Check my previous post for the manual configuration.

I cannot access the add-on via Ingress using the Tor Browser or Firefox.
We found a last minute issue impacting Firefox based browsers (including the Tor Browser). There are some issues accessing add-ons that use WebSockets. We have identified the issue and expect it to be solved with the release of Home Assistant 0.91.4.

How does one go about using the other panel_iframe items like node-red? I guess I can use the updated config as a guide.

Confirmed as a Firefox related issue on v0.94.4, in chrome it is working as intended with all add-ons using the web ui.

EDIT: same issue on v0.95.4. BTW, I’m using Firefox 67.0.4 on Kubuntu Linux 18.04.2 LTS