Configurator not working in iOS App

I am unable for some reason to reset the app.

I have the Configurator configured as an iFrame

When I try and access it from the hamburger menu I get the error:

no auth header received

I tried resetting chrome, resetting the app but no matter what I do I don’t get prompted for authentication at all it just gives the above error.

I also deleted the app and re-installed it - no change.

I once cancelled when configurator asked for username and password and no I it just comes up with an error when I try and access the configurator in the app.

Same here and didn’t find any solution so far.


I have the same problem Here.
I’ve set up SSL access, so i can access to Home Assistant and the Configurator panel from any PC with chrome.
On my ipad i can access to Configurator in safari or chrome also by using and it show me the auth box with user name and password so i can access with no problems.

But inside the Home Assistant App access to the Configurator shows no auth box and this message only “no auth header received”.

For info Node-RED configured like Configurator shows the dialog boc in ipad app and i can access to this panel.

so please what are we doing wrong with Configurator so we can’t access it from the ios app ?

The old iOS app does not work properly with configurator. The new app (currently beta) does work. Switch to the beta app…see here 1.5.0 Feedback

Thanks you working fine now .

Have a good evening

1 Like


I cannot access configurator from within the app but from Safari when on my network using https.

I can access configurator from my mac both using the panel-iframe and by opening a new tap and entering my duckdns adress when on my network.

I cannot access configurator remotely.

My setup of the configurator Addon is:

  "username": "redacted",
  "password": "redacted",
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "allowed_networks": [
  "banned_ips": [
  "banlimit": 0,
  "ignore_pattern": [
  "dirsfirst": false,
  "enforce_basepath": false,
  "notify_service": "persistent_notification.create"

The 3218 port i open.

Can you help me?

Which version of the app? BTW, is correct not

The version is 1.5.0 (21)

I changed to No difference.

Tried to connect remotely from iPad within Safari with the result “Policy not fulfilled”. I see in the log that I get:

WARNING:2018-10-18 11:07:33,170:main:Client IP banned.
INFO:2018-10-18 11:07:33,171:main: - “GET / HTTP/1.1” 420 -

Trying to connect from within the app juste renders a blank page.

Went back to the log after having tried also from my iPhone with the following additional:

INFO:2018-10-18 11:11:40,309:main: - “GET / HTTP/1.1” 401 -
WARNING:2018-10-18 11:12:00,920:main:Client IP not within allowed networks.
INFO:2018-10-18 11:12:00,921:main: - “GET / HTTP/1.1” 420 -
INFO:2018-10-18 11:12:01,905:main:Requesting authorization
INFO:2018-10-18 11:12:01,906:main: - “GET /apple-touch-icon-120x120-precomposed.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:02,643:main:Requesting authorization
INFO:2018-10-18 11:12:02,644:main: - “GET /favicon.ico HTTP/1.1” 401 -
INFO:2018-10-18 11:12:03,319:main:Requesting authorization
INFO:2018-10-18 11:12:03,321:main: - “GET /apple-touch-icon-120x120-precomposed.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:03,998:main:Requesting authorization
INFO:2018-10-18 11:12:04,000:main: - “GET /favicon.ico HTTP/1.1” 401 -
INFO:2018-10-18 11:12:04,702:main:Requesting authorization
INFO:2018-10-18 11:12:04,703:main: - “GET /apple-touch-icon-120x120.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:05,579:main:Requesting authorization
INFO:2018-10-18 11:12:05,581:main: - “GET /apple-touch-icon-120x120.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:06,444:main:Requesting authorization
INFO:2018-10-18 11:12:06,445:main: - “GET /apple-touch-icon-precomposed.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:07,298:main:Requesting authorization
INFO:2018-10-18 11:12:07,299:main: - “GET /apple-touch-icon-precomposed.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:08,179:main:Requesting authorization
INFO:2018-10-18 11:12:08,180:main: - “GET /apple-touch-icon.png HTTP/1.1” 401 -
INFO:2018-10-18 11:12:09,043:main:Requesting authorization
INFO:2018-10-18 11:12:09,044:main: - “GET /apple-touch-icon.png HTTP/1.1” 401 -