Configure Recorder to read database from a USB memory

I’ve attempted to configure the Recorder integration following, but fail to succeed. I’m running Home Assistant in a virtual environment in a Raspberry Pi 3B+.

I’ve added the db_url to my configuration.yaml

  db_url: sqlite:////media/pi/hadb/home-assistant_v2.db

I stopped Home Assistant before copying the file and changed ownership of the copied database to match the user of the virtual environment:

pi@raspberrypi:/media/pi/hadb $ ls -la -h
-rw-r--r-- 1 homeassistant homeassistant 691M Dec 25 18:20 home-assistant_v2.db

But when I start Home Assistant my home-assistant.log is showing the following error:
2020-12-25 18:41:24 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (sqlite3.OperationalError) unable to open database file
(Background on this error at: (retrying in 3 seconds)

I’ve tried a couple of suggestions including removing one / from the path as well as creating a symlink for the home-assistant_v2.db file from my config folder that point towards the USB memory. What am I doing wrong?

Best regards,

Per Takman

Tried the same with no success, maybe someone can bring some light to this question…