Configure WiFi connection

I think I found the problem. I saved the file as ANSI with notepad++ but when you reopen it and save it again, it isn’t ANSI anymore. So it’s working now! Unfortunately I can’t access hassio on that specific network, probably because it’s a guest network (Ziggo modem). When I log into the router I can see hassio is connected to the guest network, but I can’t access it. Also not when I use the ip adres instead of http://hassio.local:8123 (and yes, I’m connected to the same wireless guest network)

I am looking for that menu in the GUI, what is the full path?

I got still the same problem.
installing with ethernet no problem, wifi not possible
I also used an old image from hasbian, with the same wifi settings, and that still works.
Not a clue what I’m doing wrong ???

1 Like

Same here, impossible to access by wifi. According to the tutorial i made the usb stick injecton for config but if the wire is not connected it does not work.

using nmcli one can see that the wifi is connected but de UI isn’t reachable by wifi only.

I need to setup eduroam, which requires a custom ca_cert to be set up.

Any ideas how I can achieve this?

Many thanks

This is the method I used after trying and failing with the method where you put a file in a directory, etc. HA is brilliant but setting up WiFi is a massive omission in today’s climate and I can’t for the life of me workout why it’s not part of the setup.

For me personally, my Pi is hardwired. But I will often need to move it to pair a device so wifi is the only real option. I pair the device and. then move the Pi back to its normal location with a cable.

3 Likes

Hi guys, I read & made exactly the same described in this thread. As a test, I installed a normal Raspberry pi OS and was working the wifi and everything. But as far as I can’t have Supervision installed manually I need to go thru this procedure.

This installation method should be working better… I got the image hassos_rpi2-4.15.img.gz

Hi again,

I tried all the time with a Rasberry pi 2b, and as The Pi Hut USB Wi-Fi Adapter. With no success. I have also a raspberry pi zero w, and in this board this method was working.

I assume that there is something in the layout of the system that doesn’t enable the wifi usb sticks on the Raspberry pi 2b.

at the end a went with this method forward: Guide: Connecting Pi with Home Assistant OS to wifi (or other networking changes)

A few months ago I was trying the same with RPi4.
nmcli device wifi connect "YOUR_SSID" password "YOUR_WIFI_PASSWORD"
was the the only method working. All other methods found official docs and forum (like configuring wifi network) didn’t work.

The main problem with this particular guide is it assumes HA already installed. If you want to configure WiFI for initial start it’s almost impossibe to find complete guide (and as I said I failed to apply knowledge found in official docs). But as I said, the command found in the guide above works for initial settings to (but you have to connect monitor and keyboard to your rpi)

3 Likes

I had the same problem, an I found out my raspberry pi 3B+ only work on band channels 1- 9 and the 10-13 is not visible to it.

My fix was to go in the router setting and change the channel

Hello all,

I had the same connection problem. I think that this problem mainly affects windows users. Thx to Knulens instruction I was able to set up the wifi connection successfully. There are only additional small things to consider when creating the usb-stick and the “my-network” file. I have extended Knulen’s instructions accordingly.

USB drive:

  • max 32GB (take the smallest you have)
  • usb drive format: fat32
    ** Windows CMD: format /FS:FAT32 <YOUR-USB-DRIVE-LETTER>:
  • usb name: CONFIG
  • create folder: network
  • in this folder: my-network (file without extension)
    ** use notepad++
    ** set encoding to utf-8
    ** set EOL conversion to UNIX (Edit->EOL Conversion->UNIX)

Paste this Code in my-network-file:

[connection]
id=my-network
uuid=72111c67-4a5d-4d5c-925e-f8ee26efb3c3
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=<YOUR-WIFI-SSID>
# Uncomment below if your SSID is not broadcasted
#hidden=true

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=<YOUR-WIFI-PASSWORD>

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto
  • save the file.
  • plug the usb drive to your raspi and reboot. check your router if homeassistant appears in your network

That did it for me.

@JupiterFred ,

Thanks for sharing this - I am trying to get the WiFi working on my Intel NUC installation (should really be no different than a Pi installation - at the OS level).

I have an HP t620 ThinClient which has a miniPCI WiFi adapter (with Bluetooth 4.0 as well).

If I install Ubuntu 20.04 to this box, it sees everything in it – the m.2 SSD, the Wifi and the Bluetooth - and everything works after the install and boot.

It is driving me insane that the Hass.io shows me with an nmcli radio command that wifi is there… but I cannot for the life of me get it to work.

I have tried the USB (using a 32GB USB drive) and the folders and files like you did - still nothing. The file never gets imported (that I can find) – or used.

This really should not be this difficult.

Curtis

Hi,

This worked for me:

  1. Connect the raspberry pi to HDMI (to display the cli) and power
  2. Wait for the Home Assistant OS to boot (you should see some loading things on the monitor)
  3. When it launched the CLI (with the prompt ha >), type in the following comand: network info and find for your wifi interface (mine was wlan0)
  4. Run the following command network update <interface, for me was wlan0> --ipv4-method auto -- ipv6-method auto --wifi-auth wpa-psk --wifi-mode infrastructure --wifi-ssid <wifi name, in quotes if there’re spaces> --wifi-psk <wifi password>

This allowed me to connect my raspberry pi to the wifi network without going through the config file

7 Likes

Unfortunately this did not work…which makes no sense.

nmcli radio

shows that I have wifi adapter (shows Enabled), as do all 4 columns/settings (all show Enabled)

nmcli con show

shows an entry for wireless with a UUID – but the adapter has just – showing and it is White - whereas the Ethernet is Green.

I am dumbfounded and lost.

Curtis

This worked for me from an SSH terminal while device was still on eth0. You just invoke it as

ha network update ... (also removing the extra space before ipv6-method)

Launch a reboot, disconnect ethernet cable, and there she is on WiFi!

Hello. I’ve tried this method, and I get this on network info:
vlan: null
wifi: null

I’m using a mini PC. Any ideas of what’s happen?
Thanks in advance.

Thank you!! My desktop is MacOS, and it will not remount the flashed SD card without repairing the file system, which makes it unbootable. I was thrashing around with the CLI before reading this, works great! Thank you again!!

Thanks. This worked as expected and is way better way to set up WIFI than going through USB stick configuration file.

How can I delete previous WiFi connections & PSKs?

HA 2022.9.0b I have the WiFi set up and working on a Pi 4b. I use it as a connection to a sandboxed network however if the access point is not available it connects to previously connected AP. This is not desirable, but I see no way to “forget” previous connections.

Running HA 2022.9 on rpi3B, I can’t get make the switch from connected eth to wlan; I tried several things:

  • on UI (Settings->system->network) setting wlan IP4 fixed IO and ssid fails on save and all entered is forgotten.
  • above (@vctr) suggested HDMI connects fails; there is no HDMI signal; apparently not enabled on HA.
  • ssh (over eth) and ssh app are working, but above suggested nmcli command is not present
  • Suggested (HA doc on github) boot device file /CONFIG/network/my-network gets completely erased after booting the rpi, including the directories. Has boot changed since 2 years?
  • adding a network-config file to root of boot fat partition appears to be ignored, but I’m unsure as I cant see or log boot console output.

I have the impression that quite a lot has changed since past years, and solutions that did work, no longer do.
Any pointers to uptodate docs?