HA on Wifi

Hi, I’m completely new to HA, but just installed it on a Raspberry Pi 4 Model B, following the official HA installation guide. Everything works but can’t seem to switch over to run it over Wifi.

I connected HA to my wifi router (In Settings → System → Network → WLAN0 → Wifi it says 'Connected to '). But as soon as I unplug the Ethernet cable and restart, I can’t get in contact with HA.

Through my router I can see it has an IP-address, so I know it is has Wifi access still after reboot. I’ve tried to connect (through the browser) both homeassistant.local:8123 as well as the IP-address - nothing works.

If I replug the ethernet cable, it will work again. Even though it is connected to wifi at the same time, in Settings → System → Network → ‘Network Adapter’ I can see only one adapter - i.e. the ethernet adapter. That doesn’t seem right.

What am I missing/doing wrong? I hope someone can help, as I’ve googled for an hour now and can’t find a solution.

Thanks,
Erik

Don’t. It is a bad idea to run HA (or any server) over wifi.

2 Likes

Welcome to HA. Sorry about the previous post, sometimes we can be somewhat terse around here.

You most certainly can run HA over WiFi, I do, and have for years. No, it’s not “as good” as wired, and my preference would always have been a wired connection, based on past experience in the field. But I’m trying to get over that. Wireless networks are much better these days, and can be almost as reliable as wired.

That said, I don’t have any current instructions for setting it up. I asked this question back in early 2019 and was able to get enough hints to figure it out, but things may have changed since then. I did notice this link later that year and made a note of it then, maybe it’ll help. Even better would be to use a search engine with site:home-assistant.io and search this forum and the HA documentation.

Don’t give up, it can be done, and many of us are doing it.

1 Like

Don’t apologise for my post, it was correct.

2 Likes

hi CaptTom. Thanks for your constructive reply. I did eventually manage on my own, by following these instructions (Guide: Connecting Pi with Home Assistant OS to wifi (or other networking changes)), but with the critical extra step that was, setting wifi ip address to ‘auto’ , as it otherwise wouldn’t actually fetch an IP address from my DHCP server. I can see the links you sent me also does the same. Thanks!

1 Like

Glad I was able to help, at least a little.

For anyone stumbling onto this thread in the future, my recommendation would be to reserve an IP address for HA in your router, and use DHCP for HA. Wired or wireless, having a stable IP address makes life a lot easier going forward. At some point you’ll want to access HA remotely, and depending on the method you chose, having a consistent IP address may be necessary.

The other other option, as you found, was to define a static IP address in HA, and not use DHCP. This is a more advanced option, since your LAN address space will need to be set up to avoid duplicate addresses, and you’ll need to know your subnet and default gateway.