Configure zbbridge flashed with tasmota to work with HA

Hello everyone,
I’ve recently purchased IKEA FYRTUR window blinds and want to integrate them into my smart home. I purchased and flashed a zigbeebridge pro with tasmota with this guide and installed an MQTT broker in HA, as well as enabled the MQTT Integration on HA. Now my zbbridge communicates with the HA things like system status, for example:

MQT: tele/tasmota_4AC79C/STATE = {"Time":"2024-04-12T18:52:41","Uptime":"0T00:15:08","UptimeSec":908,"Heap":142,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"Berry":{"HeapUsed":22,"Objects":301},"Wifi":{"AP":1,"SSId":"Hrohomelab","BSSId":"28:87:BA:A1:1D:48","Channel":4,"Mode":"11n","RSSI":100,"Signal":-21,"LinkCount":1,"Downtime":"0T00:00:03"}}

My problem now is that I have absolutely no clue as to how I can pair my roller blinds with the zbbridge or HA, as before there was an option to connect devices via the tasmota interface, but after following the guide that has disappeared. I have read about Zigbee2MQTT and am wondering wether this happens on the zbbridge or HA. I also installed the Zigbee2MQTT Add on and configured in the config under serial port: tcp://[IP]:8888 instead of an usb device. The Zigbee2MQTT Add on starts and I can access the webui. The MQTT connection between the broker and the Zigbee2MQTT Server seems to be working, as when I try to add a password for the “addons” user it displays an error, whereas it does not do that when there is no password. When I try to permit join for Zigbee devices and put the blinds in pairing mode, nothing happens. (pressing the two buttons after inserting the battery on the IKEA FYRTUR after which an led comes on) While it does say the following in the Zigbee2MQTT log, the tasmota log does not show anything.

MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"8mmiz-1"}'

So there seems to be an issue between the Zigbee2MQTT Server communicating via the MQTT Broker to the zbbridge running tasmota. Also, I haven’t configured anything in the Zigbee2MQTT Server.

Am I doing anything wrong? Please give me any advice on how to imporive this setup, I would be very grateful!

Have an awesome day!

Show your Zigbee2mqtt configuration and the Zigbee2mqtt logs

Thank you for your response!

This is the yaml config file of the zigbee2mqtt add on

data_path: /config/zigbee2mqtt
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt: {}
  port: tcp://

And there is nothing in the logs tab of Zigbee2MQTT and also nothing under system > logs in HA

It turns out I used the wrong method to pair the blinds as there is little documentation how to pair them. So my setup was working properly.

For anyone wondering how it works, you have to hold both buttons of the FYRTUR for 5 seconds until the led starts blinking and then the Z2M
add on will discover it if it permits joins. What still confuses me, is as to why none of the pairing process is shown in the zbbridge tasmota log. But whatever it’s working now.