Configuring Ecolink 4655BC0-R Zigbee Door / Window sensors

It seems that Ecolink 4655BC0-R sensors (which sell for about $6 each on ebay) aren’t configured correctly by default when adding them to HA. After I added one in ZHA, an entity named binary_sensor.ecolink_4655bc0_r_a49d1511_ias_zone was added to my dashboard. It has the state “Closed”, regardless of whether I manually open or close the switch. I have verified that this is NOT a battery or connectivity issue. In fact, from the ZHA configuration page for this device, I am able to read values (get zigbee attributes) from the sensor, and the IasZone cluster’s zone_status attribute accurately reflects whether the sensor is physically open (value = ZoneStatus.Alarm_1) or closed (value = ZoneStatus.<bitmap16.0: 0>), so it is clear that this information IS available from the sensor, and that this must be a configuration problem.

EDIT: looks like when I choose to “Get Zigbee Attribute” for zone_status, then the state of the sensor gets updated on the dashboard. So it seems like some kind of issue with not polling the device, or the device not announcing when the status changes.

If someone has tried these sensors and correctly configured things, please advise on what the correct way of configuring things is. If HA doesn’t work “out of the box” with these sensors, is there anything we can do to fix that so that future versions of HA do?

I just picked up a pack of 10 of these and am disappointed since I figured they should work and I’ve run into the same issue. Really hoping to find a fix for this.

I emailed the manufacturer and basically they stated that they only have tested it with smartthings, but it does report correctly to it. So it seems maybe it isn’t recognized correctly by home assistant.

On a different note, if you remove the battery and put it back in, the device goes back to ‘looking for network’ mode and requires Home Assistant to re-pair it. Therefore, I don’t believe it is being done correctly. Not sure how to fix this.

Can confirm - these things do not work with HA. Always shows as “closed”. I thought it was my network and have spent more than two hours trying to get these to work. Changed WiFi channels, changed Zigbee channels, moved repeaters, and then moved them right next to my Zigbee controller. Then I came here and found this disappointing thread!

Having same issue with state of closed no matter what. :confused:

Has anyone had any luck with these since this thread started? I’ve updated HA Core to 0.116.3, but it still always shows “Closed”. Only the temperature updates properly. I’ve love to set up a bunch of these on on HA instead of SmartThings.

Good news this PR gets these working


This is great. Beginner question but how do we implement?

You can download the dev code of Home Assistant from GitHub and then copy the zha folder from components fo custom_components.

There have not been any big changes so this will work. Once the code is in a release you can remove the folder from custom_components

1 Like

Does anyone know if this has been incorporated into a release yet?

Just got 3 f those…anyone got them working? Or should I return / find something else?

@bgreet @DerekC @jwl173305361 @DerekC @Gamerayers @edgimar

Thanks to @tube0013’s pointer, I was able to get those sensors working.

Not sure how are you all running your HA instance, but I am on Debian -> Docker -> Home Assistant (formerly HASSIO).
This procedure is probably not recommended due to changing a HA’s core file, but hey, I took a shot and it worked!

  • Download the file will the necessary changes (not yet implemented in HA) here:
  • Using WinSCP or similar, do a search for the file in the /var/lib/docker/overlay2/ directory.
  • One of the returned file will be /var/lib/docker/overlay2/longstringofnumbersandletters/merged/usr/src/homeassistant/homeassistant/components/zha/core/channels/ (6 or 7kb) Make a backup, and replace with downloaded file above.
  • Restart HA
  • Go to HA, configuration, integrations, zigbee devices, open each device one by one and click “Reconfigure device”. You will see the state go open - close - open - close a few times, until staying stable. Congrats! Your sensor is working!

Good luck!

1 Like

this will also be in 0.118! (also a quirk I wrote so the battery % reports is in 0.118 - the min and max voltage is somewhat assumed based on other devices in the quirk).


Installed 118 this morning. Sensors still work and now we have a battery % value!
Mine are brand new showing 78%, but hey, still better than a ? symbol!

1 Like

I have the same sort of issue with ecolink flood sensor flzb1-eco. Temperature works, wet/dry only updates if you request it from the cluster screen. Anybody know if this will work for the flood sensor too, or is it signature specific?

Looks like it fixes the not enrolled problem (so the flood sensor works). The quirk to fix the battery doesn’t work, presumably because the signature is different.