Configuring my ESP32-Wroom-32 - Error resolving IP address of main-living-room-presence.local. Is it connected to WiFi?

SO i finally got esphome working in home-assistant, but i cant seem to flash my esp32 for presence detection, i got these from amazon,

The little device is on iwth a red light, but i cant seem to get it connected

INFO Reading configuration /config/esphome/main-living-room-presence.yaml...
INFO Generating C++ source...
INFO Compiling app...
Processing main-living-room-presence (board: esp32dev; framework: arduino; platform: platformio/espressif32 @ 3.5.0)
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
LDF: Library Dependency Finder ->
Dependency Graph
|-- <AsyncTCP-esphome> 1.2.2
|-- <WiFi> 1.0
|-- <FS> 1.0
|-- <Update> 1.0
|-- <ESPAsyncWebServer-esphome> 2.1.0
|   |-- <AsyncTCP-esphome> 1.2.2
|-- <DNSServer> 1.1.0
|-- <ESPmDNS> 1.0
RAM:   [=         ]  12.6% (used 41180 bytes from 327680 bytes)
Flash: [=====     ]  48.4% (used 888686 bytes from 1835008 bytes)
========================= [SUCCESS] Took 4.26 seconds =========================
INFO Successfully compiled program.
INFO Resolving IP address of main-living-room-presence.local
ERROR Error resolving IP address of main-living-room-presence.local. Is it connected to WiFi?
ERROR (If this error persists, please set a static IP address:
ERROR Error resolving IP address: Error resolving address with mDNS: Did not respond. Maybe the device is offline., [Errno -5] No address associated with hostname
  name: living-room-presence

  board: esp_wroom_02

# Enable logging
  level: INFO
# Enable Home Assistant API

  password: "cff8c2bab16b8e5d0ff6c79afe54ac05"

  ssid: !secret wifi_ssid
  password: !secret wifi_password

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Living-Room-Presence"
    password: "RcCWNEdWc9qj"


You have to flash it the first time by serial.

So how do you do that…? I was watching YouTube and the guy that was doing his didn’t flash it

Take a usb lead. Plug one end into the esp device. Plug the other end into the computer running ha/esphome.

Youtube. Nuff said.

The usb mini to usb c isn’t a serial cable?

Yes it is serial when combined with the tty/usb serial chip on the esp board.

so why cant i access is?

You are trying to flash it over wireless, but it doesn’t have any firmware yet.

yeah hence loading it from esphome over the cable… its hardwired into the mac

Is your wifi both 5ghz and 2.4ghz? I had issues with mine not reconnecting the other day and it instantly worked when I disabled the 5ghz band.

1 Like

thanks for the advice…, disabled 5ghz for now…

  • ESPHome is visited over HTTPS
  • Your browser supports WebSerial

does home assistant have to have a cert?

I think i am making progress, i think i got the firmware installed?

Please don’t post pictures of text. Copy, paste, it’s been around for 30 years or more.

Ok but thanks? How do I move forward?

Add it to home assistant. Configurations, add, esphome