Configuring nest so it show up in Overview

I can’t seem to figure this out; I have configured the nest component and climate, restarted, authenticated with Nest but nothing is showing up after that. I am hoping to find some sort of display like shown in:

Part of my configuration.yaml:

  client_id: aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa
  client_secret: aaaaaaaaaaaaaaaaaaaaaaaaa
  platform: nest

I also added this in one of the groups (even though it should already show up):

    - climate.nest

What am I doing wrong?

  client_id: aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa
  client_secret: aaaaaaaaaaaaaaaaaaaaaaaaa

Defines your nest thermostat.
Once auto discovered click on <> and searchf for your thermostat. It should be called something like climate.nest_name where nest_name is the name you gave your nest when you set it up the first time (on the nest itself, completely outside HA)

Thanks. I did get a configure box and I filled in the code but after that, it does not show up, also not in the <> climate.*
I assume that there is some sort of error connecting but I don’t know where I can find it.

you may want to start again then, something did not go according to plan. you’ll need to delete nest.conf from your config directory and you’ll need to delete the nest product from the Developer API project.

Thank you. That was it. I have the figures now at the top of the overview.
So how do I get the nice box as shown in the example?

you need to create a group for it and then list the group on your page view…
check this page for more info:

This is my config:
Nest Group:

  - climate.hallway
  - sensor.hallway_thermostat_humidity
  - binary_sensor.hallway_heating
  - binary_sensor.hallway_thermostat_has_leaf

And how I call it from one of the group views:

  view: yes
  icon: mdi:home-modern
    - light.hallway
    - group.nest

This is how it looks:

The additional sensors are template sensors extracting data from the main nest entity:

- platform: template
      value_template: >
        {{ states.sensor.hallway_thermostat_hvac_state.state == 'heating'}}
      friendly_name: Hallway Heating
      device_class: heat
1 Like

I have a great box on my screen now. Thanks!

1 Like

I just finished setting up my Nest Thermostats. I have (3):

  1. Basement
  2. Den
  3. Upstairs

I was able to set up a view on my overview page and all three thermostat display just as I wanted them to. But across the top of my overview page I have 30 icon showing all of these states:

|binary_sensor.basement_thermostat_fan|off|friendly_name: Basement Thermostat fan|
|binary_sensor.basement_thermostat_has_leaf|off|friendly_name: Basement Thermostat has leaf|
|binary_sensor.basement_thermostat_is_locked|off|friendly_name: Basement Thermostat is locked|
Basement Thermostat is using emergency heat|
|binary_sensor.basement_thermostat_online|on|friendly_name: Basement Thermostat online|
|binary_sensor.den_thermostat_fan|off|friendly_name: Den Thermostat fan|
|binary_sensor.den_thermostat_has_leaf|off|friendly_name: Den Thermostat has leaf|
|binary_sensor.den_thermostat_is_locked|off|friendly_name: Den Thermostat is locked|
Den Thermostat is using emergency heat|
|binary_sensor.den_thermostat_online|on|friendly_name: Den Thermostat online|
|binary_sensor.upstairs_thermostat_air_fan|on|friendly_name: Upstairs Thermostat (Air) fan|
|binary_sensor.upstairs_thermostat_air_has_leaf|off|friendly_name: Upstairs Thermostat (Air) has leaf|
|binary_sensor.upstairs_thermostat_air_is_locked|off|friendly_name: Upstairs Thermostat (Air) is locked|
Upstairs Thermostat (Air) is using emergency heat|
|binary_sensor.upstairs_thermostat_air_online|on|friendly_name: Upstairs Thermostat (Air) online|

How do I remove these states and only show the climate box?

Thanks for any help given.