Configuring ZWAVE on raspberry pi - Help!

You are using ACM0, not AMA0.

1 Like

Please post the actual text from your configuration.yaml. What you have posted doesn’t include the usb_path key.

LOL, oops, thanks for the catch :slight_smile:

configuration.yaml:

Configure a default setup of Home Assistant (frontend, api, etc)

default_config:

Text to speech

tts:

  • platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

zwave:
usb_path: /dev/serial/by-id/usb-0658_0200-if00

As long as the stick you got is the “Plus” version, you won’t need the USB hub, so don’t worry about that one. The Plus version of the stick runs on 3v so you don’t need to worry about the fluctuations.

If you haven’t solved this by the time I’m home from work, I’ll grab my notes from when I was setting mine up to walk you through. It took a few tries for me to get the right /dev entry at first IIRC

So I’ve got my Z-Stick Gen5 Plus connected to the top USB2 port on my Pi 4.
Interestingly, when I tried to set up the Z-Wave integration using the UI, it consistently rejected /dev/ttyACM0 as well as the /dev/serial… option, but it’s working in my configuration.yaml

Ok, so first just want to check whether your zwave: entry is indented like:

zwave:
  usb_path: /dev/ttyACM0

Or is it flat like:

zwave:
usb_path: /dev/ttyACM0

If yours is like the second option, add two spaces to the front of usb_path:

It’s the second option. I’ll add the indentation. Is /dev/ttyAMA0 ok or do I use the path /dev/serial/by-id/usb-0658_0200-if00? And do #I need to reboot the Pi ?

Both are ok, just two different ways to the same place :slight_smile:

You will need to reboot the Pi for the change to take effect.

You’ll also want to add a network key to the configuration, so you can add the smart lock securely

At the moment I’m operating the laptop controlling Home Assistant remotely, so I can tweak HA but I’m not physically present to reboot the Pi. Is there an option in HA somewhere to restart it?

Yeah you can, head here:

There is also a “Check Configuration” button in there, which essentially can tell if your configuration files are going to cause any problems trying to start up :blush: (definitely saved me a couple times)

Ok thanks FJ. I’ve restarted it and gone into the integration. Clicked Start Network and it’s saying “Starting Z-Wave network”. I guess I wait and see if it works.

1 Like

Any luck so far?

Still saying “Starting Z-Wave network”

Hmmm… no matter what I try, I can’t get mine stuck…

Can you paste the contents of your “OZW_log.txt” file? It’s in the same folder as the configuration.yaml file

Use the “code” tags in here to make it more readable(ish) :stuck_out_tongue:

Ok, it seemed stuck again. So I changed the usb path back to /dev/serial/by-id/usb-0658_0200-if00 with indentations this time. Removed the Z-Wave integration. Restarted HA from scratch. And we have success! I’m seeing “Z-Wave network started All nodes have been queried.” So in the next few hours I’ll go round and physically try and get the lock to talk to the network. Many thanks FJ.

1 Like

Oh awesome!
Don’t forget to add the network key to your configuration. Security devices require it for “Secure Inclusion” so that all communication between the lock and the Z-Wave controller are encrypted.

Thanks, yes I added a random network key when I changed the configuration.yaml file. And it didn’t complain about it so presumably it worked.

That’s basically as good as it gets with computers :laughing:

If you open the OZW_log.txt file in your configuration folder, it should say at the top, like 3rd or 4th line that it accepted the key or started with the key, if you want explicit confirmation :blush:

OK I think I’ve got my lock talking to HA, but I don’t see how I can unlock it or add a code using HA. It appears as “Unknown Node 3(Node:3 Complete)”. It has an entity called “lock.unknown_node_3_locked”.
But where should the commands appear to change the lock? I tried deleting it and re-pairing it but the delete node command doesn’t seem to do anything.

It sounds like the lock didn’t finish its interview by that point, given that it is being listed as “unknown node 3”.
Has it started working properly over the day today or is it still the same?

If it’s still the same, try selecting the node in the Z-Wave control panel (where the start and stop network buttons are) and pressing the “refresh node” button, and then unlock the lock to wake it up and have it complete it’s interview. Might take a minute or two, but I think you get some feedback appearing in the UI (all my nodes are mains powered so I never had to manually get them interviewing).

Also, what is the model of the lock and the module you plugged into the lock, out of interest?